低危 Spring Framework up to 4.3.17/5.0.6 MVC HTTP Request 跨站脚本攻击

CVE编号

CVE-2018-11039

利用情况

暂无

补丁情况

官方补丁

披露时间

2018-06-26
漏洞描述
Spring Framework(5.0.7之前的5.0.x版本,4.3.18之前的版本4.3.x以及较旧的不受支持的版本)允许Web应用程序使用Spring中的HiddenHttpMethodFilter将HTTP请求方法更改为任何HTTP方法(包括TRACE) MVC。如果应用程序具有预先存在的XSS漏洞,则恶意用户(或攻击者)可以使用此过滤器升级到XST(跨站点跟踪)攻击。<br>
解决建议
目前厂商已发布升级补丁以修复漏洞,补丁获取链接:
https://pivotal.io/security/cve-2018-11039
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 pivotal_software spring_framework * From
(including)
4.3.0
Up to
(excluding)
4.3.18
运行在以下环境
应用 pivotal_software spring_framework * From
(including)
5.0.0
Up to
(excluding)
5.0.7
运行在以下环境
系统 debian_9 libspring-java * Up to
(excluding)
4.3.5-1+deb9u1
运行在以下环境
系统 ubuntu_18.04.5_lts libspring-java * Up to
(excluding)
4.3.19-1
运行在以下环境
系统 ubuntu_18.10 libspring-java * Up to
(excluding)
4.3.19-1
阿里云评分
2.7
  • 攻击路径
    远程
  • 攻击复杂度
    困难
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
NVD-CWE-noinfo
阿里云安全产品覆盖情况