Undertow File Descriptor URLResource.getLastModified() 拒绝服务漏洞

CVE编号

CVE-2018-1114

利用情况

暂无

补丁情况

N/A

披露时间

2018-09-12
漏洞描述
发现Undertow中的URLResource.getLastModified()仅在文件描述符完成后才关闭,这可能导致文件描述符耗尽。这导致文件处理程序泄漏。
解决建议
目前厂商已发布升级补丁以修复漏洞,补丁获取链接:
https://access.redhat.com/errata/RHSA-2018:2643
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 redhat undertow - -
运行在以下环境
应用 redhat virtualization 4.0 -
运行在以下环境
应用 redhat virtualization 4.2 -
运行在以下环境
应用 redhat virtualization_host 4.0 -
CVSS3评分
6.5
  • 攻击路径
    网络
  • 攻击复杂度
  • 权限要求
  • 影响范围
    未更改
  • 用户交互
  • 可用性
  • 保密性
  • 完整性
CWE-ID 漏洞类型
CWE-400 未加控制的资源消耗(资源穷尽)
阿里云安全产品覆盖情况