中危 polkitd中polkit_backend_interactive_authority_check_authorization函数的授权不正确

CVE编号

CVE-2018-1116

利用情况

暂无

补丁情况

官方补丁

披露时间

2018-07-11
漏洞描述
在版本0.116之前的polkit中发现了一个缺陷。 polkitd中polkit_backend_interactive_authority_check_authorization函数的实现允许测试身份验证并触发其他用户拥有的不相关进程的身份验证。这可能导致本地DoS和信息泄露。

解决建议
建议您更新当前系统或软件至最新版,完成漏洞的修复。
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 polkit_project polkit * Up to
(excluding)
0.115
运行在以下环境
系统 canonical ubuntu_linux 12.04 -
运行在以下环境
系统 debian debian_linux 8.0 -
运行在以下环境
系统 redhat_7 polkit * Up to
(excluding)
0:0.112-26.el7
运行在以下环境
系统 sles_12 libpolkit0-32bit * Up to
(excluding)
0.113-5.12
运行在以下环境
系统 suse_12 libpolkit0-32bit * Up to
(excluding)
0.113-5.12
运行在以下环境
系统 ubuntu_14.04.6_lts policykit-1 * Up to
(excluding)
0.105-4ubuntu3.14.04.2
运行在以下环境
系统 ubuntu_14.04_lts policykit-1 * Up to
(excluding)
0.105-4ubuntu3.14.04.2
运行在以下环境
系统 ubuntu_16.04.7_lts policykit-1 * Up to
(excluding)
0.105-14.1ubuntu0.1
运行在以下环境
系统 ubuntu_16.04_lts policykit-1 * Up to
(excluding)
0.105-14.1ubuntu0.1
运行在以下环境
系统 ubuntu_18.04.5_lts policykit-1 * Up to
(excluding)
0.105-20ubuntu0.18.04.1
运行在以下环境
系统 ubuntu_18.04_lts policykit-1 * Up to
(excluding)
0.105-20ubuntu0.18.04.1
阿里云评分
5.4
  • 攻击路径
    本地
  • 攻击复杂度
    容易
  • 权限要求
    无需权限
  • 影响范围
    越权影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    数据泄露
  • 数据完整性
    无影响
  • 服务器危害
    DoS
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-862 授权机制缺失
阿里云安全产品覆盖情况