低危 procps-ng 至 3.3.14 mmap 内存破坏漏洞

CVE编号

CVE-2018-1123

利用情况

暂无

补丁情况

官方补丁

披露时间

2018-05-24
漏洞描述
procps-ng是一款使用在Linux平台中的用于提供proc文件系统进程信息的实用程序。 procps-ng 3.3.15之前版本中的ps存在安全漏洞。攻击者可利用该漏洞造成短暂的拒绝服务(缓冲区溢出和崩溃)。

解决建议
目前厂商已发布升级补丁以修复漏洞,详情请关注厂商主页:
https://gitlab.com/procps-ng/procps
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 procps-ng_project procps-ng * Up to
(excluding)
3.3.15
运行在以下环境
系统 alpine_3.10 git * Up to
(excluding)
2.17.1-r0
运行在以下环境
系统 alpine_3.11 git * Up to
(excluding)
2.17.1-r0
运行在以下环境
系统 alpine_3.12 git * Up to
(excluding)
2.17.1-r0
运行在以下环境
系统 alpine_3.13 git * Up to
(excluding)
2.17.1-r0
运行在以下环境
系统 alpine_3.5 git * Up to
(excluding)
2.11.3-r1
运行在以下环境
系统 alpine_3.6 git * Up to
(excluding)
2.13.7
运行在以下环境
系统 alpine_3.7 git * Up to
(excluding)
2.15.2-r0
运行在以下环境
系统 alpine_3.8 git * Up to
(excluding)
2.17.1-r0
运行在以下环境
系统 alpine_3.9 git * Up to
(excluding)
2.17.1-r0
运行在以下环境
系统 alpine_edge git * Up to
(excluding)
2.17.1-r0
运行在以下环境
系统 amazon_2 git * Up to
(excluding)
2.14.4-1.amzn2
运行在以下环境
系统 amazon_AMI git * Up to
(excluding)
2.14.4-2.58.amzn1
运行在以下环境
系统 centos_7 git * Up to
(excluding)
1.8.3.1-14.el7_5
运行在以下环境
系统 debian_7 git * Up to
(excluding)
1:3.3.3-3+deb7u1
运行在以下环境
系统 debian_8 git * Up to
(excluding)
2:3.3.9-9+deb8u1
运行在以下环境
系统 debian_9 git * Up to
(excluding)
2:3.3.12-3+deb9u1
运行在以下环境
系统 fedora_27 git * Up to
(excluding)
0.26.4-1.fc27
运行在以下环境
系统 fedora_28 git * Up to
(excluding)
0.26.4-1.fc28
运行在以下环境
系统 fedora_EPEL_7 git * Up to
(excluding)
0.26.4-1.el7
运行在以下环境
系统 opensuse_Leap_15.0 git * Up to
(excluding)
3.3.15-lp150.5.3.1
运行在以下环境
系统 opensuse_Leap_15.1 git * Up to
(excluding)
3.3.15-lp151.6.3.1
运行在以下环境
系统 opensuse_Leap_42.3 git * Up to
(excluding)
3.3.9-23.1
运行在以下环境
系统 oracle_7 git * Up to
(excluding)
2.17-260.0.9.ksplice1.el7
运行在以下环境
系统 suse_11_SP4 git * Up to
(excluding)
3.2.7-152.31.1
运行在以下环境
系统 suse_12_SP3 git * Up to
(excluding)
2.12.3-27.14.1
运行在以下环境
系统 suse_12_SP4 git * Up to
(excluding)
3.3.9-11.18.1
运行在以下环境
系统 ubuntu_14.04 git * Up to
(excluding)
1:3.3.9-1ubuntu2.3
运行在以下环境
系统 ubuntu_16.04 git * Up to
(excluding)
2:3.3.10-4ubuntu2.4
运行在以下环境
系统 ubuntu_18.04 git * Up to
(excluding)
2:3.3.12-3ubuntu1.1
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-119 内存缓冲区边界内操作的限制不恰当
CWE-122 堆缓冲区溢出
阿里云安全产品覆盖情况