低危 glibc 基于堆的缓冲区溢出导致任意代码执行

CVE编号

CVE-2018-11236

利用情况

暂无

补丁情况

官方补丁

披露时间

2018-05-19
漏洞描述
GNU C库(aka glibc或libc6)2.27及更早版本中的stdlib / canonicalize.c,当处理非常长的路径名参数到realpath函数时,可能会遇到32位体系结构上的整数溢出,导致基于堆栈的缓冲区溢出并且,可能是任意代码执行。

解决建议
目前厂商已发布升级补丁以修复漏洞,详情请关注厂商主页:
https://www.gnu.org/software/libc/
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 gnu glibc * Up to
(including)
2.27
运行在以下环境
应用 netapp data_ontap_edge - -
运行在以下环境
应用 netapp element_software_management - -
运行在以下环境
应用 oracle communications_session_border_controller 8.0.0 -
运行在以下环境
应用 oracle communications_session_border_controller 8.1.0 -
运行在以下环境
应用 oracle communications_session_border_controller 8.2.0 -
运行在以下环境
应用 oracle enterprise_communications_broker 3.0.0 -
运行在以下环境
应用 oracle enterprise_communications_broker 3.1.0 -
运行在以下环境
应用 redhat virtualization_host 4.0 -
运行在以下环境
系统 amazon_2 glibc * Up to
(excluding)
2.26-28.amzn2.0.1
运行在以下环境
系统 amazon_AMI glibc * Up to
(excluding)
2.17-260.175.amzn1
运行在以下环境
系统 debian_9 glibc * Up to
(excluding)
2.24-11+deb9u4
运行在以下环境
系统 opensuse_Leap_15.0 glibc * Up to
(excluding)
2.26-lp150.11.6.120
运行在以下环境
系统 opensuse_Leap_42.3 glibc * Up to
(excluding)
2.22-19.2
运行在以下环境
系统 oracle_7 glibc * Up to
(excluding)
2.17-260.0.9.ksplice1.el7
运行在以下环境
系统 suse_11_SP4 glibc * Up to
(excluding)
2.11.3-17.110.14.1
运行在以下环境
系统 suse_12_SP3 glibc * Up to
(excluding)
2.22-62.13.2
运行在以下环境
系统 ubuntu_16.04 glibc * Up to
(excluding)
2.23-0ubuntu11.2
运行在以下环境
系统 ubuntu_18.04 glibc * Up to
(excluding)
2.27-3ubuntu1.2
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-190 整数溢出或超界折返
CWE-787 跨界内存写
阿里云安全产品覆盖情况