低危 UPX拒绝服务漏洞

CVE编号

CVE-2018-11243

利用情况

暂无

补丁情况

官方补丁

披露时间

2018-05-19
漏洞描述
UPX是一款可执行文件压缩器。

UPX 3.95版本中的p_lx_elf.cpp文件的‘PackLinuxElf64::unpack’函数存在安全漏洞。远程攻击者可借助特制的文件利用该漏洞造成拒绝服务(双重释放)。
解决建议
目前厂商暂未发布修复措施解决此安全问题,建议使用此软件的用户随时关注厂商主页或参考网址以获取解决办法:
https://upx.github.io/
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 upx_project upx 3.95 -
运行在以下环境
系统 alpine_3.12 upx * Up to
(excluding)
3.96-r0
运行在以下环境
系统 alpine_3.13 upx * Up to
(excluding)
3.96-r0
运行在以下环境
系统 alpine_3.14 upx * Up to
(excluding)
3.96-r0
运行在以下环境
系统 alpine_3.15 upx * Up to
(excluding)
3.96-r0
运行在以下环境
系统 alpine_edge upx * Up to
(excluding)
3.96-r0
运行在以下环境
系统 fedora_30 upx * Up to
(excluding)
3.96-1.fc30
运行在以下环境
系统 fedora_31 upx * Up to
(excluding)
3.96-2.fc31
运行在以下环境
系统 fedora_EPEL_7 upx * Up to
(excluding)
3.96-1.el7
运行在以下环境
系统 fedora_EPEL_8 upx * Up to
(excluding)
3.96-1.el8
运行在以下环境
系统 opensuse_Leap_15.1 upx * Up to
(excluding)
3.96-lp151.3.3.1
阿里云评分
2.9
  • 攻击路径
    本地
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-415 双重释放
阿里云安全产品覆盖情况