低危 procps-ng套件pgrep命令缓冲区溢出漏洞

CVE编号

CVE-2018-1125

利用情况

暂无

补丁情况

官方补丁

披露时间

2018-05-24
漏洞描述
procps-ng套件3.3.15之前的版本中的pgrep存在缓冲区溢出漏洞。由于procps-ng套件编译时均加载了fortify,该漏洞仅造成应用程序崩溃.

解决建议
目前厂商已发布升级补丁以修复漏洞,详情请关注厂商主页:
https://gitlab.com/procps-ng/procps
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 procps-ng_project procps-ng * Up to
(excluding)
3.3.15
运行在以下环境
系统 alpine_3.13 procps * Up to
(excluding)
0.9.6-r0
运行在以下环境
系统 alpine_edge procps * Up to
(excluding)
0.9.6-r0
运行在以下环境
系统 debian_10 procps * Up to
(excluding)
0.9.6+dfsg-5
运行在以下环境
系统 debian_11 procps * Up to
(excluding)
0.9.6+dfsg-5
运行在以下环境
系统 debian_7 procps * Up to
(excluding)
1:3.3.3-3+deb7u1
运行在以下环境
系统 debian_8 procps * Up to
(excluding)
2:3.3.9-9+deb8u1
运行在以下环境
系统 debian_9 procps * Up to
(excluding)
2:3.3.12-3+deb9u1
运行在以下环境
系统 debian_sid procps * Up to
(excluding)
0.9.6+dfsg-5
运行在以下环境
系统 fedora_29 procps * Up to
(excluding)
0.9.6-5.fc29
运行在以下环境
系统 opensuse_Leap_15.0 procps * Up to
(excluding)
3.3.15-lp150.5.3.1
运行在以下环境
系统 opensuse_Leap_15.1 procps * Up to
(excluding)
3.3.15-lp151.6.3.1
运行在以下环境
系统 opensuse_Leap_42.3 procps * Up to
(excluding)
3.3.9-23.1
运行在以下环境
系统 suse_11_SP4 procps * Up to
(excluding)
3.2.7-152.31.1
运行在以下环境
系统 suse_12_SP3 procps * Up to
(excluding)
3.3.9-11.18.1
运行在以下环境
系统 suse_12_SP4 procps * Up to
(excluding)
3.3.9-11.18.1
运行在以下环境
系统 ubuntu_14.04 procps * Up to
(excluding)
1:3.3.9-1ubuntu2.3
运行在以下环境
系统 ubuntu_16.04 procps * Up to
(excluding)
2:3.3.10-4ubuntu2.4
运行在以下环境
系统 ubuntu_18.04 procps * Up to
(excluding)
2:3.3.12-3ubuntu1.1
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-787 跨界内存写
阿里云安全产品覆盖情况