低危 Red Hat Ceph弱签名漏洞

CVE编号

CVE-2018-1129

利用情况

暂无

补丁情况

官方补丁

披露时间

2018-07-11
漏洞描述
Red Hat Ceph是美国红帽(Red Hat)公司的一套Linux PB级分布式文件系统。该系统的主要目标是设计成基于POSIX(可移植操作系统接口)的没有单点故障的分布式文件系统,使数据能容错和无缝的复制。Ceph branches master、mimic、luminous和jewel都是不同的Ceph版本。 Red Hat Ceph中存在安全漏洞,该漏洞源于程序使用了较弱的签名。攻击者可利用该漏洞绕过cephx协议的签名检测。

解决建议
目前厂商已发布升级补丁以修复漏洞,补丁获取链接:
http://tracker.ceph.com/issues/24837
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 ceph ceph 10.2.0 -
运行在以下环境
应用 ceph ceph 10.2.1 -
运行在以下环境
应用 ceph ceph 10.2.10 -
运行在以下环境
应用 ceph ceph 10.2.11 -
运行在以下环境
应用 ceph ceph 10.2.2 -
运行在以下环境
应用 ceph ceph 10.2.3 -
运行在以下环境
应用 ceph ceph 10.2.4 -
运行在以下环境
应用 ceph ceph 10.2.5 -
运行在以下环境
应用 ceph ceph 10.2.6 -
运行在以下环境
应用 ceph ceph 10.2.7 -
运行在以下环境
应用 ceph ceph 10.2.8 -
运行在以下环境
应用 ceph ceph 10.2.9 -
运行在以下环境
应用 ceph ceph 12.2.0 -
运行在以下环境
应用 ceph ceph 12.2.1 -
运行在以下环境
应用 ceph ceph 12.2.2 -
运行在以下环境
应用 ceph ceph 12.2.3 -
运行在以下环境
应用 ceph ceph 12.2.4 -
运行在以下环境
应用 ceph ceph 12.2.5 -
运行在以下环境
应用 ceph ceph 12.2.6 -
运行在以下环境
应用 ceph ceph 12.2.7 -
运行在以下环境
应用 ceph ceph 13.2.0 -
运行在以下环境
应用 ceph ceph 13.2.1 -
运行在以下环境
应用 redhat ceph_storage 1.3 -
运行在以下环境
应用 redhat ceph_storage 3 -
运行在以下环境
应用 redhat ceph_storage_mon 2 -
运行在以下环境
应用 redhat ceph_storage_mon 3 -
运行在以下环境
应用 redhat ceph_storage_osd 2 -
运行在以下环境
应用 redhat ceph_storage_osd 3 -
运行在以下环境
系统 debian_8 linux-4.9 * Up to
(excluding)
4.9.144-3.1~deb8u1
运行在以下环境
系统 debian_9 linux-4.9 * Up to
(excluding)
10.2.11-1
运行在以下环境
系统 fedora_27 linux-4.9 * Up to
(excluding)
12.2.7-1.fc27
运行在以下环境
系统 fedora_28 linux-4.9 * Up to
(excluding)
12.2.6-1.fc28
运行在以下环境
系统 opensuse_Leap_15.0 linux-4.9 * Up to
(excluding)
13.2.4.125
运行在以下环境
系统 opensuse_Leap_42.3 linux-4.9 * Up to
(excluding)
4.4.155-68.1
运行在以下环境
系统 suse_12 kernel-default-extra * Up to
(excluding)
4.12.14-94.41
运行在以下环境
系统 suse_12_SP3 linux-4.9 * Up to
(excluding)
4.4.155-4.16.1
运行在以下环境
系统 ubuntu_16.04.7_lts ceph * Up to
(excluding)
10.2.11-0ubuntu0.16.04.1
运行在以下环境
系统 ubuntu_18.04.5_lts ceph * Up to
(excluding)
12.2.7-0ubuntu0.18.04.1
运行在以下环境
系统 ubuntu_18.10 ceph * Up to
(excluding)
13.2.4+dfsg1-0ubuntu0.18.10.1
阿里云评分
2.9
  • 攻击路径
    本地
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-287 认证机制不恰当
阿里云安全产品覆盖情况