中危 Sinatra up to 2.0.1 400 Page Request 跨站脚本攻击

CVE编号

CVE-2018-11627

利用情况

暂无

补丁情况

官方补丁

披露时间

2018-06-01
漏洞描述
Sinatra是一种基于Ruby的用于创建Web应用程序的域专用语言。

Sinatra 2.0.2之前版本中存在跨站脚本漏洞。远程攻击可借助400 Bad Request页面利用该漏洞注入任意的Web脚本或HTML。
解决建议
目前厂商已发布升级补丁以修复漏洞,补丁获取链接:
https://github.com/sinatra/sinatra/commit/12786867d6faaceaec62c7c2cb5b0e2dc074d71a
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 redhat cloudforms 4.6 -
运行在以下环境
应用 redhat cloudforms 4.7 -
运行在以下环境
应用 sinatrarb sinatra * Up to
(excluding)
2.0.2
运行在以下环境
系统 fedora_27 rubygem-sinatra * Up to
(excluding)
2.0.0-3.fc27
运行在以下环境
系统 fedora_27 rubygem-sinatra-doc * Up to
(excluding)
2.0.0-3.fc27
运行在以下环境
系统 fedora_28 rubygem-sinatra * Up to
(excluding)
2.0.0-4.fc28
运行在以下环境
系统 fedora_28 rubygem-sinatra-doc * Up to
(excluding)
2.0.0-4.fc28
阿里云评分
4.9
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    越权影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-79 在Web页面生成时对输入的转义处理不恰当(跨站脚本)
阿里云安全产品覆盖情况