Joyent SmartOS权限提升漏洞

CVE编号

CVE-2018-1171

利用情况

暂无

补丁情况

N/A

披露时间

2018-03-20
漏洞描述
Joyent SmartOS是美国Joyent公司的一套开源的操作系统。

Joyent SmartOS release-20170803-20170803T064301Z版本中的DTrace DOF文件存在安全漏洞,该漏洞源于程序为难正确的校验用户提交的数据。本地攻击者可利用该漏洞提升权限,执行代码。
解决建议
目前厂商已发布升级补丁以修复漏洞,补丁获取链接:
https://help.joyent.com/hc/en-us/articles/360000608188
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
系统 centos_7 gvfs * Up to
(excluding)
1.36.2-5.el7_9
运行在以下环境
系统 debian_9 webkit2gtk * Up to
(excluding)
0.2.7386~beta20.3-3+deb9u3
运行在以下环境
系统 joyent smartos 20170803-20170803t064301z -
运行在以下环境
系统 opensuse_Leap_15.0 webkit2gtk * Up to
(excluding)
0.3.9-lp150.2.3.1
运行在以下环境
系统 opensuse_Leap_42.3 webkit2gtk * Up to
(excluding)
2.20.3-11.1
运行在以下环境
系统 oracle solaris 10 -
运行在以下环境
系统 oracle solaris 11.3 -
运行在以下环境
系统 redhat_7 adwaita-cursor-theme * Up to
(excluding)
0:3.28.0-1.el7
运行在以下环境
系统 sles_12 libwebkit2gtk3-lang * Up to
(excluding)
2.20.3-2.23
运行在以下环境
系统 sles_12_SP3 webkit2gtk * Up to
(excluding)
2.20.3-2.23.8
运行在以下环境
系统 suse_12_SP3 gvfs * Up to
(excluding)
18-2.20.3-2.23.8
运行在以下环境
系统 ubuntu_16.04_lts webkit2gtk * Up to
(excluding)
2.20.2-0ubuntu0.16.04.1
运行在以下环境
系统 ubuntu_18.04_lts webkit2gtk * Up to
(excluding)
2.20.2-0ubuntu0.18.04.1
CVSS3评分
7.0
  • 攻击路径
    本地
  • 攻击复杂度
  • 权限要求
  • 影响范围
    未更改
  • 用户交互
  • 可用性
  • 保密性
  • 完整性
CWE-ID 漏洞类型
CWE-787 跨界内存写
阿里云安全产品覆盖情况