低危 WebSocket连接的TLS证书验证不正确

CVE编号

CVE-2018-11712

利用情况

暂无

补丁情况

官方补丁

披露时间

2018-06-05
漏洞描述
在WebKitGTK+ 版本 2.20.0 和2.20.1中使用的WebKit的libsoup网络后端中的WebCore/platform/network/soup/SocketStreamHandleImplSoup.cpp未能对WebSocket连接执行TLS证书验证。<br><br>
解决建议
建议您更新当前系统或软件至最新版,完成漏洞的修复。
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 webkitgtk webkitgtk+ 2.20.0 -
运行在以下环境
应用 webkitgtk webkitgtk+ 2.20.1 -
运行在以下环境
系统 centos_7 gvfs * Up to
(excluding)
1.36.2-5.el7_9
运行在以下环境
系统 debian_9 webkit2gtk * Up to
(including)
2.18.6-1~deb9u1
运行在以下环境
系统 opensuse_Leap_42.3 webkit2gtk * Up to
(excluding)
2.20.3-11.1
运行在以下环境
系统 redhat_7 adwaita-cursor-theme * Up to
(excluding)
0:3.28.0-1.el7
运行在以下环境
系统 sles_12 libwebkit2gtk3-lang * Up to
(excluding)
2.20.3-2.23
运行在以下环境
系统 sles_12_SP3 webkit2gtk * Up to
(excluding)
2.20.3-2.23.8
运行在以下环境
系统 suse_12 libwebkit2gtk3-lang * Up to
(excluding)
2.20.3-2.23
运行在以下环境
系统 suse_12_SP3 gvfs * Up to
(excluding)
18-2.20.3-2.23.8
运行在以下环境
系统 ubuntu_16.04 gvfs * Up to
(excluding)
2.20.2-0ubuntu0.16.04.1
运行在以下环境
系统 ubuntu_16.04.7_lts webkit2gtk * Up to
(excluding)
2.20.2-0ubuntu0.16.04.1
运行在以下环境
系统 ubuntu_16.04_lts webkit2gtk * Up to
(excluding)
2.20.2-0ubuntu0.16.04.1
运行在以下环境
系统 ubuntu_18.04 gvfs * Up to
(excluding)
2.20.2-0ubuntu0.18.04.1
运行在以下环境
系统 ubuntu_18.04.5_lts webkit2gtk * Up to
(excluding)
2.20.2-0ubuntu0.18.04.1
运行在以下环境
系统 ubuntu_18.04_lts webkit2gtk * Up to
(excluding)
2.20.2-0ubuntu0.18.04.1
运行在以下环境
系统 ubuntu_18.10 webkit2gtk * Up to
(excluding)
2.20.2-1
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-295 证书验证不恰当
阿里云安全产品覆盖情况