低危 Apache HTTP Server 至 2.4.34 SETTINGS Frame 输入验证漏洞

CVE编号

CVE-2018-11763

利用情况

暂无

补丁情况

官方补丁

披露时间

2018-09-26
漏洞描述
在Apache HTTP Server 2.4.17到2.4.34中,通过发送连续的大型 SETTINGS frames,客户端可以占用连接,服务器线程和CPU时间,而不会出现任何连接超时。这仅影响HTTP / 2  connections 。一种可能的缓解措施是不启用h2协议。

解决建议
厂商已发布了漏洞修复程序,请及时关注更新:
https://httpd.apache.org/security/vulnerabilities_24.html
参考链接
http://lists.opensuse.org/opensuse-security-announce/2019-06/msg00030.html
http://lists.opensuse.org/opensuse-security-announce/2019-07/msg00056.html
http://www.securityfocus.com/bid/105414
http://www.securitytracker.com/id/1041713
https://access.redhat.com/errata/RHSA-2018:3558
https://access.redhat.com/errata/RHSA-2019:0366
https://access.redhat.com/errata/RHSA-2019:0367
https://httpd.apache.org/security/vulnerabilities_24.html
https://lists.apache.org/thread.html/56c2e7cc9deb1c12a843d0dc251ea7fd3e7e8029...
https://lists.apache.org/thread.html/84a3714f0878781f6ed84473d1a503d2cc382277...
https://lists.apache.org/thread.html/r06f0d87ebb6d59ed8379633f36f72f5b1f79cad...
https://lists.apache.org/thread.html/r15f9aa4427581a1aecb4063f1b4b983511ae1c9...
https://lists.apache.org/thread.html/r6521a7f62276340eabdb3339b2aa9a38c5f59d9...
https://lists.apache.org/thread.html/r76142b8c5119df2178be7c2dba88fde552eedee...
https://lists.apache.org/thread.html/r9f93cf6dde308d42a9c807784e8102600d0397f...
https://lists.apache.org/thread.html/rc998b18880df98bafaade071346690c2bc1444a...
https://lists.apache.org/thread.html/rd18c3c43602e66f9cdcf09f1de233804975b957...
https://lists.apache.org/thread.html/re3d27b6250aa8548b8845d314bb8a350b3df326...
https://lists.apache.org/thread.html/rf6449464fd8b7437704c55f88361b66f12d5b5f...
https://lists.apache.org/thread.html/rfcf929bd33a6833e3f0c35eebdad70d5060665f...
https://security.netapp.com/advisory/ntap-20190204-0004/
https://support.hpe.com/hpsc/doc/public/display?docLocale=en_US&docId=emr_na-...
https://usn.ubuntu.com/3783-1/
https://www.oracle.com/technetwork/security-advisory/cpuapr2019-5072813.html
https://www.oracle.com/technetwork/security-advisory/cpujan2019-5072801.html
https://www.tenable.com/security/tns-2019-09
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 apache http_server * From
(including)
2.4.17
Up to
(including)
2.4.34
运行在以下环境
应用 netapp storage_automation_store - -
运行在以下环境
应用 oracle enterprise_manager_ops_center 12.3.3 -
运行在以下环境
应用 oracle hospitality_guest_access 4.2.0 -
运行在以下环境
应用 oracle hospitality_guest_access 4.2.1 -
运行在以下环境
应用 oracle instantis_enterprisetrack 17.1 -
运行在以下环境
应用 oracle instantis_enterprisetrack 17.2 -
运行在以下环境
应用 oracle instantis_enterprisetrack 17.3 -
运行在以下环境
应用 oracle retail_xstore_point_of_service 7.0 -
运行在以下环境
应用 oracle retail_xstore_point_of_service 7.1 -
运行在以下环境
应用 oracle secure_global_desktop 5.4 -
运行在以下环境
系统 alpine_3.10 httpd * Up to
(excluding)
2.4.35-r0
运行在以下环境
系统 alpine_3.11 httpd * Up to
(excluding)
2.4.35-r0
运行在以下环境
系统 alpine_3.12 httpd * Up to
(excluding)
2.4.35-r0
运行在以下环境
系统 alpine_3.13 httpd * Up to
(excluding)
2.4.35-r0
运行在以下环境
系统 alpine_3.14 httpd * Up to
(excluding)
2.4.35-r0
运行在以下环境
系统 alpine_3.15 httpd * Up to
(excluding)
2.4.35-r0
运行在以下环境
系统 alpine_3.5 httpd * Up to
(excluding)
2.4.35-r0
运行在以下环境
系统 alpine_3.6 httpd * Up to
(excluding)
2.4.35-r0
运行在以下环境
系统 alpine_3.7 httpd * Up to
(excluding)
2.4.35-r0
运行在以下环境
系统 alpine_3.8 httpd * Up to
(excluding)
2.4.35-r0
运行在以下环境
系统 alpine_3.9 httpd * Up to
(excluding)
2.4.35-r0
运行在以下环境
系统 alpine_edge httpd * Up to
(excluding)
2.4.35-r0
运行在以下环境
系统 amazon_2 httpd * Up to
(excluding)
2.4.37-1.amzn2.0.1
运行在以下环境
系统 amazon_AMI httpd * Up to
(excluding)
2.4.37-1.83.amzn1
运行在以下环境
系统 debian_9 httpd * Up to
(excluding)
2.4.25-3+deb9u6
运行在以下环境
系统 fedora_27 httpd * Up to
(excluding)
1.11.1-1.fc27
运行在以下环境
系统 fedora_28 httpd * Up to
(excluding)
1.11.1-1.fc28
运行在以下环境
系统 fedora_29 httpd * Up to
(excluding)
1.11.1-1.fc29
运行在以下环境
系统 opensuse_Leap_15.0 httpd * Up to
(excluding)
2.4.33-lp150.2.6.1
运行在以下环境
系统 opensuse_Leap_15.1 httpd * Up to
(excluding)
6.0.10-lp151.2.6.1
运行在以下环境
系统 opensuse_Leap_42.3 httpd * Up to
(excluding)
2.4.23-31.1
运行在以下环境
系统 suse_12_SP3 httpd * Up to
(excluding)
2.4.23-29.27.2
运行在以下环境
系统 suse_12_SP4 httpd * Up to
(excluding)
2.4.23-29.27.2
运行在以下环境
系统 ubuntu_18.04 httpd * Up to
(excluding)
2.4.29-1ubuntu4.4
阿里云评分
2.7
  • 攻击路径
    远程
  • 攻击复杂度
    困难
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
NVD-CWE-noinfo
阿里云安全产品覆盖情况