Foxit Reader GIF DataSubBlock越界读信息泄露漏洞

CVE编号

CVE-2018-1179

利用情况

暂无

补丁情况

N/A

披露时间

2018-05-18
漏洞描述
Foxit Reader是一款小型的PDF文档查看器和打印程序。

Foxit Reader在GIF图形DataSubBlock结构解析中存在安全漏洞,由于缺少用户提供的数据的适当验证,导致攻击者可利用漏洞获取敏感信息。
解决建议
目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:
https://www.foxitsoftware.com/support/security-bulletins.php
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 foxitsoftware foxit_reader * Up to
(including)
9.0.1.1049
运行在以下环境
应用 foxitsoftware phantompdf * Up to
(including)
9.0.1.1049
运行在以下环境
系统 debian_8 libpdfbox-java * Up to
(excluding)
1:1.8.7+dfsg-1+deb8u2
运行在以下环境
系统 debian_9 libpdfbox-java * Up to
(excluding)
1.8.12-1
运行在以下环境
系统 fedora_29 libpdfbox-java * Up to
(excluding)
2.0.16-1.fc29
运行在以下环境
系统 fedora_30 libpdfbox-java * Up to
(excluding)
2.0.16-1.fc30
运行在以下环境
系统 fedora_31 libpdfbox-java * Up to
(excluding)
2.0.16-1.fc31
运行在以下环境
系统 opensuse_Leap_15.0 libpdfbox-java * Up to
(excluding)
1.8.12-lp150.4.6.1
运行在以下环境
系统 opensuse_Leap_42.3 libpdfbox-java * Up to
(excluding)
1.8.12-4.3.1
运行在以下环境
系统 ubuntu_14.04.6_lts libreoffice * Up to
(excluding)
1:4.2.8-0ubuntu5.5
运行在以下环境
系统 ubuntu_16.04.7_lts libreoffice * Up to
(excluding)
1:5.1.6~rc2-0ubuntu1~xenial4
运行在以下环境
系统 ubuntu_18.04.5_lts libpdfbox-java * Up to
(excluding)
1:1.8.16-2~18.04
运行在以下环境
系统 ubuntu_18.10 libpdfbox-java * Up to
(excluding)
1:1.8.16-2~18.04
CVSS3评分
6.5
  • 攻击路径
    网络
  • 攻击复杂度
  • 权限要求
  • 影响范围
    未更改
  • 用户交互
    需要
  • 可用性
  • 保密性
  • 完整性
CWE-ID 漏洞类型
CWE-125 跨界内存读
阿里云安全产品覆盖情况