低危 Apache OpenOffice Arithmetic Overflow漏洞

CVE编号

CVE-2018-11790

利用情况

暂无

补丁情况

官方补丁

披露时间

2019-02-01
漏洞描述
使用Apache Open Office 4.1.5及更早版本加载文档时,使用比操作系统使用的端线更小的终端,会出现缺陷。在这种情况下,OpenOffice会在字符串长度计算时遇到 Arithmetic Overflow。

解决建议
厂商已发布了漏洞修复程序,请及时关注更新:
https://www.openoffice.org/security/cves/CVE-2018-11790.html
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 apache open_office * Up to
(including)
4.1.5
运行在以下环境
系统 ubuntu_14.04.6_lts libreoffice * Up to
(excluding)
1:4.2.8-0ubuntu5.5
运行在以下环境
系统 ubuntu_14.04_lts libreoffice * Up to
(excluding)
1:4.2.8-0ubuntu5.5
运行在以下环境
系统 ubuntu_16.04.7_lts libreoffice * Up to
(excluding)
1:5.1.6~rc2-0ubuntu1~xenial4
运行在以下环境
系统 ubuntu_16.04_lts libreoffice * Up to
(excluding)
1:5.1.6~rc2-0ubuntu1~xenial4
运行在以下环境
系统 ubuntu_18.04 libreoffice * Up to
(excluding)
1:6.0.7-0ubuntu0.18.04.2
运行在以下环境
系统 ubuntu_18.04.5_lts libreoffice * Up to
(excluding)
1:6.0.7-0ubuntu0.18.04.2
运行在以下环境
系统 ubuntu_18.04_lts libreoffice * Up to
(excluding)
1:6.0.7-0ubuntu0.18.04.2
阿里云评分
2.6
  • 攻击路径
    本地
  • 攻击复杂度
    复杂
  • 权限要求
    普通权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-682 数值计算不正确
阿里云安全产品覆盖情况