低危 Spring Security和Spring Framework认证绕过漏洞

CVE编号

CVE-2018-1199

利用情况

暂无

补丁情况

官方补丁

披露时间

2018-03-17
漏洞描述
Spring Security是一套为基于Spring的应用程序提供说明性安全保护的安全框架。Spring Framework是美国Pivotal公司的一套开源的Java、Java EE应用程序框架。

Spring Security和Spring Framework认证绕过漏洞。远程攻击者可以绕过身份验证,获得对服务器的访问,并且可以公开信息。
解决建议
用户可参考如下供应商提供的安全公告获得补丁信息:
https://jvndb.jvn.jp/en/contents/2018/JVNDB-2018-000008.html
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 pivotal_software spring_framework * From
(including)
4.3.0
Up to
(including)
4.3.13
运行在以下环境
应用 pivotal_software spring_framework * From
(including)
5.0.0
Up to
(including)
5.0.2
运行在以下环境
应用 pivotal_software spring_security * From
(including)
4.1.0
Up to
(including)
4.1.4
运行在以下环境
应用 pivotal_software spring_security * From
(including)
4.2.0
Up to
(including)
4.2.3
运行在以下环境
应用 pivotal_software spring_security 5.0.0 -
运行在以下环境
系统 debian_9 libspring-java * Up to
(including)
4.3.5-1
运行在以下环境
系统 ubuntu_18.04.5_lts libspring-java * Up to
(excluding)
4.3.14-1
运行在以下环境
系统 ubuntu_18.10 libspring-java * Up to
(excluding)
4.3.14-1
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-20 输入验证不恰当
阿里云安全产品覆盖情况