中危 Eclipse OpenJ9代码执行漏洞

CVE编号

CVE-2018-12547

利用情况

暂无

补丁情况

官方补丁

披露时间

2019-02-12
漏洞描述
Eclipse OpenJ9是Eclipse基金会的一款Java应用程序引擎。该产品主要用于运行Java应用程序。

Eclipse OpenJ9 0.12.0之前版本中存在缓冲区溢出漏洞,该漏洞源于网络系统或产品在内存上执行操作时,未正确验证数据边界,导致向关联的其他内存位置上执行了错误的读写操作。攻击者可利用该漏洞导致缓冲区溢出或堆溢出等。
解决建议
目前厂商已发布升级补丁以修复漏洞,补丁获取链接:
https://bugs.eclipse.org/bugs/show_bug.cgi?id=543659
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 eclipse openj9 * Up to
(excluding)
0.12.0
运行在以下环境
应用 redhat satellite 5.8 -
运行在以下环境
系统 centos_8 java-1.8.0-ibm-webstart * Up to
(excluding)
1.8.0.5.35-3.el8_0
运行在以下环境
系统 redhat_8 java-1.8.0-ibm-plugin * Up to
(excluding)
1.8.0.5.35-3.el8_0
运行在以下环境
系统 suse_12 java-1_7_1-ibm * Up to
(excluding)
1.7.1_sr4.50-38.41
阿里云评分
6.9
  • 攻击路径
    远程
  • 攻击复杂度
    容易
  • 权限要求
    无需权限
  • 影响范围
    全局影响
  • EXP成熟度
    N/A
  • 补丁情况
    官方补丁
  • 数据保密性
    数据泄露
  • 数据完整性
    传输被破坏
  • 服务器危害
    DoS
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-119 内存缓冲区边界内操作的限制不恰当
阿里云安全产品覆盖情况