安全绕过漏洞

CVE编号

CVE-2018-1282

利用情况

暂无

补丁情况

N/A

披露时间

2018-04-06
漏洞描述
Apache Hive JDBC驱动程序0.7.1至2.3.2中的此漏洞允许使用经过精心设计的参数来绕过JDBC驱动程序在PreparedStatement实现中进行的参数转义或者清除。
解决建议
建议您更新当前系统或软件至最新版,完成漏洞的修复。
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 apache hive * From
(including)
0.7.1
Up to
(including)
2.3.2
运行在以下环境
系统 ubuntu_14.04.6_lts adobe-flashplugin * Up to
(excluding)
30.0.0.154ubuntu0.14.04.1
运行在以下环境
系统 ubuntu_14.04_lts adobe-flashplugin * Up to
(excluding)
30.0.0.154ubuntu0.14.04.1
运行在以下环境
系统 ubuntu_16.04.7_lts adobe-flashplugin * Up to
(excluding)
30.0.0.154ubuntu0.16.04.1
运行在以下环境
系统 ubuntu_18.04.5_lts adobe-flashplugin * Up to
(excluding)
30.0.0.154ubuntu0.18.04.1
CVSS3评分
9.1
  • 攻击路径
    网络
  • 攻击复杂度
  • 权限要求
  • 影响范围
    未更改
  • 用户交互
  • 可用性
  • 保密性
  • 完整性
CWE-ID 漏洞类型
CWE-89 SQL命令中使用的特殊元素转义处理不恰当(SQL注入)
阿里云安全产品覆盖情况