低危 LibTIFF堆缓冲区溢出漏洞(CNVD-2018-14921)

CVE编号

CVE-2018-12900

利用情况

暂无

补丁情况

官方补丁

披露时间

2018-06-27
漏洞描述
Libtiff是一个用于读取和写入标记图像文件格式(缩写为TIFF)文件的库。 LibTIFF 4.0.9中的tiffcp.c中的cpSeparateBufToContigBuf函数存在基于堆的缓冲区溢出漏洞。远程攻击者可通过特制TIFF文件利用该漏洞导致拒绝服务(崩溃)或可能造成其他影响。

解决建议
厂商尚未提供漏洞修复方案,请关注厂商主页更新:
http://www.simplesystems.org/libtiff/
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 libtiff libtiff 4.0.9 -
运行在以下环境
系统 alibaba_cloud_linux_2.1903 tiff * Up to
(excluding)
4.0.3-32.1.al7
运行在以下环境
系统 alpine_3.10 tiff * Up to
(excluding)
4.0.10-r0
运行在以下环境
系统 alpine_3.11 tiff * Up to
(excluding)
4.0.10-r0
运行在以下环境
系统 alpine_3.12 tiff * Up to
(excluding)
4.0.10-r0
运行在以下环境
系统 alpine_3.13 tiff * Up to
(excluding)
4.0.10-r0
运行在以下环境
系统 alpine_3.14 tiff * Up to
(excluding)
4.0.10-r0
运行在以下环境
系统 alpine_3.15 tiff * Up to
(excluding)
4.0.10-r0
运行在以下环境
系统 alpine_3.16 tiff * Up to
(excluding)
4.0.10-r0
运行在以下环境
系统 alpine_3.6 tiff * Up to
(excluding)
4.0.10-r0
运行在以下环境
系统 alpine_3.7 tiff * Up to
(excluding)
4.0.10-r0
运行在以下环境
系统 alpine_3.8 tiff * Up to
(excluding)
4.0.10-r0
运行在以下环境
系统 alpine_3.9 tiff * Up to
(excluding)
4.0.10-r0
运行在以下环境
系统 alpine_edge tiff * Up to
(excluding)
4.0.10-r0
运行在以下环境
系统 amazon_2 tiff * Up to
(excluding)
4.0.3-32.amzn2
运行在以下环境
系统 amazon_AMI tiff * Up to
(excluding)
4.0.3-32.34.amzn1
运行在以下环境
系统 centos_8 tiff * Up to
(excluding)
4.0.9-15.el8
运行在以下环境
系统 debian_8 tiff * Up to
(excluding)
4.0.3-12.3+deb8u10
运行在以下环境
系统 debian_9 tiff * Up to
(excluding)
4.0.8-2+deb9u5
运行在以下环境
系统 opensuse_Leap_15.0 tiff * Up to
(excluding)
4.0.9-lp150.4.9.1
运行在以下环境
系统 opensuse_Leap_42.3 tiff * Up to
(excluding)
4.0.9-40.1
运行在以下环境
系统 oracle_7 tiff * Up to
(excluding)
4.0.3-32.el7
运行在以下环境
系统 oracle_8 tiff * Up to
(excluding)
4.0.9-15.el8
运行在以下环境
系统 redhat_7 libtiff * Up to
(excluding)
0:4.0.3-32.el7
运行在以下环境
系统 redhat_8 tiff * Up to
(excluding)
4.0.9-15.el8
运行在以下环境
系统 suse_11_SP4 tiff * Up to
(excluding)
3.8.2-141.169.22.1
运行在以下环境
系统 suse_12 libtiff5 * Up to
(excluding)
4.0.9-44.27
运行在以下环境
系统 suse_12_SP3 tiff * Up to
(excluding)
4.0.9-44.27.1
运行在以下环境
系统 suse_12_SP4 tiff * Up to
(excluding)
4.0.9-44.27.1
运行在以下环境
系统 ubuntu_14.04 tiff * Up to
(excluding)
4.0.3-7ubuntu0.11
运行在以下环境
系统 ubuntu_14.04.6_lts tiff * Up to
(excluding)
4.0.3-7ubuntu0.11
运行在以下环境
系统 ubuntu_16.04 tiff * Up to
(excluding)
4.0.6-1ubuntu0.6
运行在以下环境
系统 ubuntu_16.04.7_lts tiff * Up to
(excluding)
4.0.6-1ubuntu0.6
运行在以下环境
系统 ubuntu_18.04 tiff * Up to
(excluding)
4.0.9-5ubuntu0.2
运行在以下环境
系统 ubuntu_18.04.5_lts tiff * Up to
(excluding)
4.0.9-5ubuntu0.2
运行在以下环境
系统 ubuntu_18.10 tiff * Up to
(excluding)
4.0.9-6ubuntu0.2
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-787 跨界内存写
阿里云安全产品覆盖情况