低危 Apache HTTP Server up to 2.4.29 HTTP Header Crash 拒绝服务漏洞

CVE编号

CVE-2018-1301

利用情况

暂无

补丁情况

官方补丁

披露时间

2018-03-27
漏洞描述
在版本2.4.30之前,由于读取HTTP header达到大小限制后的超越界访问,一个特别精心设计的请求可能会导致Apache HTTP服务器崩溃。如果在非调试模式(日志和构建级别)中不可能触发此漏洞,则该漏洞被认为是非常困难的,因此它被归类为常见服务器使用的低风险。&nbsp;<br />
&nbsp;

解决建议
目前厂商已发布升级补丁以修复漏洞,补丁获取链接:
https://httpd.apache.org/security/vulnerabilities_24.html
参考链接
http://www.openwall.com/lists/oss-security/2018/03/24/2
http://www.securityfocus.com/bid/103515
http://www.securitytracker.com/id/1040573
https://access.redhat.com/errata/RHSA-2018:3558
https://access.redhat.com/errata/RHSA-2019:0366
https://access.redhat.com/errata/RHSA-2019:0367
https://httpd.apache.org/security/vulnerabilities_24.html
https://lists.apache.org/thread.html/56c2e7cc9deb1c12a843d0dc251ea7fd3e7e8029...
https://lists.apache.org/thread.html/84a3714f0878781f6ed84473d1a503d2cc382277...
https://lists.apache.org/thread.html/r06f0d87ebb6d59ed8379633f36f72f5b1f79cad...
https://lists.apache.org/thread.html/r15f9aa4427581a1aecb4063f1b4b983511ae1c9...
https://lists.apache.org/thread.html/r6521a7f62276340eabdb3339b2aa9a38c5f59d9...
https://lists.apache.org/thread.html/r76142b8c5119df2178be7c2dba88fde552eedee...
https://lists.apache.org/thread.html/r9f93cf6dde308d42a9c807784e8102600d0397f...
https://lists.apache.org/thread.html/rc998b18880df98bafaade071346690c2bc1444a...
https://lists.apache.org/thread.html/rd18c3c43602e66f9cdcf09f1de233804975b957...
https://lists.apache.org/thread.html/rd336919f655b7ff309385e34a143e41c503e133...
https://lists.apache.org/thread.html/re3d27b6250aa8548b8845d314bb8a350b3df326...
https://lists.apache.org/thread.html/rf6449464fd8b7437704c55f88361b66f12d5b5f...
https://lists.apache.org/thread.html/rfcf929bd33a6833e3f0c35eebdad70d5060665f...
https://lists.debian.org/debian-lts-announce/2018/05/msg00020.html
https://security.netapp.com/advisory/ntap-20180601-0004/
https://support.hpe.com/hpsc/doc/public/display?docLocale=en_US&docId=emr_na-...
https://usn.ubuntu.com/3627-1/
https://usn.ubuntu.com/3627-2/
https://usn.ubuntu.com/3937-2/
https://www.debian.org/security/2018/dsa-4164
https://www.tenable.com/security/tns-2019-09
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 apache http_server * Up to
(including)
2.4.29
运行在以下环境
应用 netapp santricity_cloud_connector - -
运行在以下环境
应用 netapp storagegrid - -
运行在以下环境
应用 netapp storage_automation_store - -
运行在以下环境
系统 redhat_7 httpd * Up to
(excluding)
0:2.4.6-93.el7
运行在以下环境
系统 suse_12 apache2 * Up to
(excluding)
2.4.16-20.16
运行在以下环境
系统 ubuntu_14.04_lts apache2 * Up to
(excluding)
2.4.7-1ubuntu4.20
运行在以下环境
系统 ubuntu_16.04_lts apache2 * Up to
(excluding)
2.4.18-2ubuntu3.8
运行在以下环境
系统 ubuntu_18.04_lts apache2 * Up to
(excluding)
2.4.29-1ubuntu4.1
运行在以下环境
系统 ubuntu_18.10 apache2 * Up to
(excluding)
2.4.29-1ubuntu4.1
阿里云评分
2.7
  • 攻击路径
    远程
  • 攻击复杂度
    困难
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-119 内存缓冲区边界内操作的限制不恰当
阿里云安全产品覆盖情况