Apache Spark欺骗漏洞

CVE编号

CVE-2018-1334

利用情况

暂无

补丁情况

N/A

披露时间

2018-07-13
漏洞描述
Apache Spark是一款支持非循环数据流和内存计算的大规模数据处理引擎。

Apache Spark 1.0.0版本至2.1.2版本、2.2.0版本至2.2.1版本和2.3.0版本在实现中存在欺骗漏洞。当运行PySpark和SparkR时,本地攻击者可利用该漏洞连接到Spark应用程序上并冒充用户。
解决建议
目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:
https://spark.apache.org/security.html#CVE-2018-1334
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 apache spark * Up to
(including)
2.1.2
运行在以下环境
应用 apache spark * From
(including)
2.2.0
Up to
(including)
2.2.1
运行在以下环境
应用 apache spark 2.3.0 -
运行在以下环境
系统 alibaba_cloud_linux_2.1903 mercurial * Up to
(excluding)
2.6.2-10.1.al7
运行在以下环境
系统 debian_8 mercurial * Up to
(excluding)
3.1.2-2+deb8u4
运行在以下环境
系统 debian_9 mercurial * Up to
(excluding)
4.0-1+deb9u2
运行在以下环境
系统 opensuse_Leap_15.0 mercurial * Up to
(excluding)
4.5.2-lp150.2.3.1
运行在以下环境
系统 opensuse_Leap_42.3 mercurial * Up to
(excluding)
4.2.3-15.1
运行在以下环境
系统 oracle_7 mercurial * Up to
(excluding)
2.6.2-10.el7
运行在以下环境
系统 redhat_7 emacs-mercurial * Up to
(excluding)
0:2.6.2-10.el7
运行在以下环境
系统 ubuntu_14.04.6_lts mercurial * Up to
(excluding)
2.8.2-1ubuntu1.4
运行在以下环境
系统 ubuntu_16.04.7_lts mercurial * Up to
(excluding)
3.7.3-1ubuntu1.1
运行在以下环境
系统 ubuntu_18.04.5_lts mercurial * Up to
(excluding)
4.5.3-1ubuntu2.1
运行在以下环境
系统 ubuntu_18.10 mercurial * Up to
(excluding)
4.6.1-1ubuntu1
CVSS3评分
4.7
  • 攻击路径
    本地
  • 攻击复杂度
  • 权限要求
  • 影响范围
    未更改
  • 用户交互
  • 可用性
  • 保密性
  • 完整性
CWE-ID 漏洞类型
CWE-200 信息暴露
阿里云安全产品覆盖情况