低危 mpatch.c中的长度检查不正确

CVE编号

CVE-2018-13348

利用情况

暂无

补丁情况

官方补丁

披露时间

2018-07-06
漏洞描述
在4.6.1之前的Mercurial中的mpatch.c中的mpatch_decode函数错误地处理了在补丁数据中当前位置之后应该至少剩余12个字节的某些情况,但实际上不是,也就是OVE-20180430-0001。

解决建议
建议您更新当前系统或软件至最新版,完成漏洞的修复。
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 mercurial mercurial * Up to
(excluding)
4.6.1
运行在以下环境
系统 debian_8 mercurial * Up to
(excluding)
3.1.2-2+deb8u4
运行在以下环境
系统 debian_9 mercurial * Up to
(excluding)
4.0-1+deb9u2
运行在以下环境
系统 opensuse_Leap_15.0 mercurial * Up to
(excluding)
4.5.2-lp150.2.3.1
运行在以下环境
系统 opensuse_Leap_42.3 mercurial * Up to
(excluding)
4.2.3-15.1
运行在以下环境
系统 ubuntu_14.04 mercurial * Up to
(excluding)
2.8.2-1ubuntu1.4
运行在以下环境
系统 ubuntu_14.04.6_lts mercurial * Up to
(excluding)
2.8.2-1ubuntu1.4
运行在以下环境
系统 ubuntu_16.04 mercurial * Up to
(excluding)
3.7.3-1ubuntu1.1
运行在以下环境
系统 ubuntu_16.04.7_lts mercurial * Up to
(excluding)
3.7.3-1ubuntu1.1
运行在以下环境
系统 ubuntu_18.04 mercurial * Up to
(excluding)
4.5.3-1ubuntu2.1
运行在以下环境
系统 ubuntu_18.04.5_lts mercurial * Up to
(excluding)
4.5.3-1ubuntu2.1
运行在以下环境
系统 ubuntu_18.10 mercurial * Up to
(excluding)
4.6.1-1ubuntu1
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-20 输入验证不恰当
阿里云安全产品覆盖情况