中危 Bootstrap up to 4.1.1 tooltip 跨站脚本攻击

CVE编号

CVE-2018-14042

利用情况

暂无

补丁情况

官方补丁

披露时间

2018-07-14
漏洞描述
Bootstrap是一款使用HTML、CSS和JavaScript开发的开源Web前端框架。

Bootstrap 4.1.2之前版本中的tooltip的data-container属性存在跨站脚本漏洞。远程攻击者可利用该漏洞注入任意的Web脚本或HTML。
解决建议
目前厂商已发布升级补丁以修复漏洞,补丁获取链接:
https://blog.getbootstrap.com/2018/07/12/bootstrap-4-1-2/
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 getbootstrap bootstrap * Up to
(excluding)
3.4.0
运行在以下环境
应用 getbootstrap bootstrap * From
(including)
4.0.0
Up to
(excluding)
4.1.2
运行在以下环境
应用 getbootstrap bootstrap 4.0.0 -
运行在以下环境
系统 alibaba_cloud_linux_2.1903 ipa * Up to
(excluding)
4.6.8-5.1.al7
运行在以下环境
系统 amazon linux_2 ipa * Up to
(excluding)
4.6.8-5.amzn2
运行在以下环境
系统 amazon_2 ipa * Up to
(excluding)
4.6.8-5.amzn2
运行在以下环境
系统 centos_8 ipa * Up to
(excluding)
4.8.7-12.module+el8.3.0+8222+c1bff54a
运行在以下环境
系统 debian_9 ipa * Up to
(excluding)
3.3.7+dfsg-2+deb9u1
运行在以下环境
系统 oracle linux_7 ipa * Up to
(excluding)
4.6.8-5.0.1.el7
运行在以下环境
系统 oracle_7 ipa * Up to
(excluding)
4.6.8-5.0.1.el7
运行在以下环境
系统 oracle_8 ipa * Up to
(excluding)
0.6.0-3.module+el8.3.0+7868+2151076c
运行在以下环境
系统 redhat_7 ipa-client * Up to
(excluding)
0:4.6.8-5.el7
运行在以下环境
系统 redhat_8 ipa * Up to
(excluding)
4.8.7-12.module+el8.3.0+8222+c1bff54a
阿里云评分
4.9
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    越权影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-79 在Web页面生成时对输入的转义处理不恰当(跨站脚本)
阿里云安全产品覆盖情况