低危 imap / util.c中的整数下溢

CVE编号

CVE-2018-14353

利用情况

暂无

补丁情况

官方补丁

披露时间

2018-07-18
漏洞描述
在1.10.1之前的Mutt和2018-07-16之前的NeoMutt中发现了一个问题。 imap / util.c中的imap_quote_string有一个整数下溢。

解决建议
厂商已发布了漏洞修复程序,请及时关注更新:
https://gitlab.com/muttmua/mutt/commit/e0131852c6059107939893016c8ff56b6e42865d;https://github.com/neomutt/neomutt/commit/65d64a5b60a4a3883f2cd799d92c6091d8854f23
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 mutt mutt * Up to
(excluding)
1.10.1
运行在以下环境
应用 neomutt neomutt * Up to
(excluding)
20180716
运行在以下环境
系统 alpine_3.5 mutt * Up to
(excluding)
1.10.1-r0
运行在以下环境
系统 alpine_3.6 mutt * Up to
(excluding)
1.10.1-r0
运行在以下环境
系统 alpine_3.7 mutt * Up to
(excluding)
1.10.1-r0
运行在以下环境
系统 alpine_3.8 mutt * Up to
(excluding)
1.10.1-r0
运行在以下环境
系统 canonical ubuntu_linux 14.04 -
运行在以下环境
系统 canonical ubuntu_linux 16.04 -
运行在以下环境
系统 canonical ubuntu_linux 18.04 -
运行在以下环境
系统 debian debian_linux 8.0 -
运行在以下环境
系统 debian debian_linux 9.0 -
运行在以下环境
系统 debian_8 mutt * Up to
(excluding)
1.5.23-3+deb8u1
运行在以下环境
系统 debian_9 mutt * Up to
(excluding)
1.7.2-1+deb9u1
运行在以下环境
系统 fedora_27 mutt * Up to
(excluding)
1.9.2-2.fc27
运行在以下环境
系统 fedora_28 mutt * Up to
(excluding)
1.10.1-1.fc28
运行在以下环境
系统 opensuse_Leap_15.0 mutt * Up to
(excluding)
1.10.1-lp150.2.3.1
运行在以下环境
系统 opensuse_Leap_42.3 mutt * Up to
(excluding)
1.10.1-2.5.1
运行在以下环境
系统 sles_11_SP4 mutt * Up to
(excluding)
1.5.17-42.43.1
运行在以下环境
系统 sles_12 mutt * Up to
(excluding)
1.10.1-55.6
运行在以下环境
系统 sles_12_SP3 mutt * Up to
(excluding)
1.10.1-55.3.1
运行在以下环境
系统 suse_11_SP4 mutt * Up to
(excluding)
1.5.17-42.43.1
运行在以下环境
系统 suse_12 mutt * Up to
(excluding)
1.10.1-55.6
运行在以下环境
系统 suse_12_SP3 mutt * Up to
(excluding)
1.10.1-55.3.1
运行在以下环境
系统 ubuntu_14.04.6_lts mutt * Up to
(excluding)
1.5.21-6.4ubuntu2.2
运行在以下环境
系统 ubuntu_14.04_lts mutt * Up to
(excluding)
1.5.21-6.4ubuntu2.2
运行在以下环境
系统 ubuntu_16.04 mutt * Up to
(excluding)
1.5.24-1ubuntu0.1
运行在以下环境
系统 ubuntu_16.04.7_lts mutt * Up to
(excluding)
1.5.24-1ubuntu0.1
运行在以下环境
系统 ubuntu_16.04_lts mutt * Up to
(excluding)
1.5.24-1ubuntu0.1
运行在以下环境
系统 ubuntu_18.04 mutt * Up to
(excluding)
1.9.4-3ubuntu0.1
运行在以下环境
系统 ubuntu_18.04.5_lts mutt * Up to
(excluding)
1.9.4-3ubuntu0.1
运行在以下环境
系统 ubuntu_18.04_lts mutt * Up to
(excluding)
1.9.4-3ubuntu0.1
运行在以下环境
系统 ubuntu_18.10 mutt * Up to
(excluding)
1.10.1-1
运行在以下环境
系统 ubuntu_20.04 mutt * Up to
(excluding)
1.10.1-1
运行在以下环境
系统 ubuntu_21.04 mutt * Up to
(excluding)
1.10.1-1
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-191 整数下溢(超界折返)
阿里云安全产品覆盖情况