低危 Mutt/NeoMutt IMAP Server 命令注入漏洞

CVE编号

CVE-2018-14354

利用情况

暂无

补丁情况

官方补丁

披露时间

2018-07-18
漏洞描述
在1.10.1之前的Mutt和2018-07-16之前的NeoMutt中发现了一个问题。它们允许远程IMAP服务器通过反引号字符执行任意命令,该命令与与手动订阅或取消订阅相关联的邮箱命令相关。

解决建议
厂商已发布了漏洞修复程序,请及时关注更新:
https://gitlab.com/muttmua/mutt/commit/185152818541f5cdc059cbff3f3e8b654fc27c1d;https://github.com/neomutt/neomutt/commit/95e80bf9ff10f68cb6443f760b85df4117cb15eb
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 mutt mutt * Up to
(excluding)
1.10.1
运行在以下环境
应用 neomutt neomutt * Up to
(excluding)
20180716
运行在以下环境
系统 canonical ubuntu_linux 12.04 -
运行在以下环境
系统 canonical ubuntu_linux 14.04 -
运行在以下环境
系统 canonical ubuntu_linux 16.04 -
运行在以下环境
系统 canonical ubuntu_linux 18.04 -
运行在以下环境
系统 debian debian_linux 8.0 -
运行在以下环境
系统 debian debian_linux 9.0 -
运行在以下环境
系统 redhat enterprise_linux_desktop 6.0 -
运行在以下环境
系统 redhat enterprise_linux_desktop 7.0 -
运行在以下环境
系统 redhat enterprise_linux_server 6.0 -
运行在以下环境
系统 redhat enterprise_linux_server 7.0 -
运行在以下环境
系统 redhat enterprise_linux_server_aus 7.6 -
运行在以下环境
系统 redhat enterprise_linux_server_aus 7.7 -
运行在以下环境
系统 redhat enterprise_linux_server_eus 7.5 -
运行在以下环境
系统 redhat enterprise_linux_server_eus 7.6 -
运行在以下环境
系统 redhat enterprise_linux_server_eus 7.7 -
运行在以下环境
系统 redhat enterprise_linux_server_tus 7.6 -
运行在以下环境
系统 redhat enterprise_linux_server_tus 7.7 -
运行在以下环境
系统 redhat enterprise_linux_workstation 6.0 -
运行在以下环境
系统 redhat enterprise_linux_workstation 7.0 -
运行在以下环境
系统 redhat_7 mutt * Up to
(excluding)
5:1.5.21-28.el7_5
运行在以下环境
系统 sles_12 mutt * Up to
(excluding)
1.10.1-55.6
运行在以下环境
系统 suse_12 mutt * Up to
(excluding)
1.10.1-55.6
运行在以下环境
系统 ubuntu_14.04.6_lts mutt * Up to
(excluding)
1.5.21-6.4ubuntu2.2
运行在以下环境
系统 ubuntu_14.04_lts mutt * Up to
(excluding)
1.5.21-6.4ubuntu2.2
运行在以下环境
系统 ubuntu_16.04.7_lts mutt * Up to
(excluding)
1.5.24-1ubuntu0.1
运行在以下环境
系统 ubuntu_16.04_lts mutt * Up to
(excluding)
1.5.24-1ubuntu0.1
运行在以下环境
系统 ubuntu_18.04.5_lts mutt * Up to
(excluding)
1.9.4-3ubuntu0.1
运行在以下环境
系统 ubuntu_18.04_lts mutt * Up to
(excluding)
1.9.4-3ubuntu0.1
运行在以下环境
系统 ubuntu_18.10 mutt * Up to
(excluding)
1.10.1-1
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-78 OS命令中使用的特殊元素转义处理不恰当(OS命令注入)
阿里云安全产品覆盖情况