低危 xmlXPathCompOpEval() 可以允许攻击者导致拒绝服务

CVE编号

CVE-2018-14404

利用情况

暂无

补丁情况

官方补丁

披露时间

2018-07-20
漏洞描述
 libxml2 through 2.9.8 的 xpath.c:xmlXPathCompOpEval()函数中存在空指针解引用漏洞,当在 XPath _ Op _ and 或 xpath _使用 libxml2 库处理不可信 XSL 格式输入的应用程序可能会因为应用程序崩溃而容易受到拒绝服务攻击。

解决建议
目前厂商暂未发布修复措施解决此安全问题,建议使用此软件的用户随时关注厂商主页或参考网址以获取解决办法:
http://xmlsoft.org/
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 xmlsoft libxml2 * Up to
(including)
2.9.8
运行在以下环境
系统 canonical ubuntu_linux 12.04 -
运行在以下环境
系统 canonical ubuntu_linux 14.04 -
运行在以下环境
系统 canonical ubuntu_linux 16.04 -
运行在以下环境
系统 canonical ubuntu_linux 18.04 -
运行在以下环境
系统 debian debian_linux - -
运行在以下环境
系统 redhat_7 libxml2 * Up to
(excluding)
0:2.9.1-6.el7.4
运行在以下环境
系统 sles_12 libxml2 * Up to
(excluding)
2.9.4-46.15
运行在以下环境
系统 suse_12 libxml2 * Up to
(excluding)
2.9.4-46.15
运行在以下环境
系统 ubuntu_14.04.6_lts libxml2 * Up to
(excluding)
2.9.1+dfsg1-3ubuntu4.13
运行在以下环境
系统 ubuntu_14.04_lts libxml2 * Up to
(excluding)
2.9.1+dfsg1-3ubuntu4.13
运行在以下环境
系统 ubuntu_16.04.7_lts libxml2 * Up to
(excluding)
2.9.3+dfsg1-1ubuntu0.6
运行在以下环境
系统 ubuntu_16.04_lts libxml2 * Up to
(excluding)
2.9.3+dfsg1-1ubuntu0.6
运行在以下环境
系统 ubuntu_18.04.5_lts libxml2 * Up to
(excluding)
2.9.4+dfsg1-6.1ubuntu1.2
运行在以下环境
系统 ubuntu_18.04_lts libxml2 * Up to
(excluding)
2.9.4+dfsg1-6.1ubuntu1.2
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-476 空指针解引用
阿里云安全产品覆盖情况