低危 Libgd up to 2.2.5 gd.c gdImageClone 拒绝服务漏洞

CVE编号

CVE-2018-14553

利用情况

暂无

补丁情况

官方补丁

披露时间

2020-02-12
漏洞描述
从libgd 2.1.0-rc2到2.2.5的gd.c中的gdImageClone具有NULL指针取消引用,允许攻击者通过特定的函数调用序列使应用程序崩溃。仅在与外部libgd(未捆绑)链接时才影响PHP。
解决建议
目前厂商已发布升级补丁以修复漏洞,补丁获取链接:https://github.com/fcabralpacheco/libgd/commit/441cbfed60ebf6cb63b8ce120ed0a82b15e7aaf8
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 libgd libgd * From
(including)
2.1.1
Up to
(including)
2.2.5
运行在以下环境
应用 libgd libgd 2.1.0 -
运行在以下环境
系统 alpine_3.10 gd * Up to
(excluding)
2.2.5-r3
运行在以下环境
系统 alpine_3.11 gd * Up to
(excluding)
2.2.5-r3
运行在以下环境
系统 alpine_3.12 gd * Up to
(excluding)
2.3.0-r0
运行在以下环境
系统 alpine_3.13 gd * Up to
(excluding)
2.3.0-r0
运行在以下环境
系统 alpine_3.14 gd * Up to
(excluding)
2.3.0-r0
运行在以下环境
系统 alpine_3.15 gd * Up to
(excluding)
2.3.0-r0
运行在以下环境
系统 alpine_3.16 gd * Up to
(excluding)
2.3.0-r0
运行在以下环境
系统 alpine_3.8 gd * Up to
(excluding)
2.2.5-r3
运行在以下环境
系统 alpine_3.9 gd * Up to
(excluding)
2.2.5-r3
运行在以下环境
系统 alpine_edge gd * Up to
(excluding)
2.3.0-r0
运行在以下环境
系统 centos_8 gd * Up to
(excluding)
2.2.5-7.el8
运行在以下环境
系统 debian_10 gd * Up to
(including)
2.2.5-5.2
运行在以下环境
系统 debian_8 gd * Up to
(excluding)
2.1.0-5+deb8u9
运行在以下环境
系统 debian_9 gd * Up to
(including)
2.2.4-2+deb9u5
运行在以下环境
系统 fedora_32 gd * Up to
(excluding)
2.3.0-1.fc32
运行在以下环境
系统 opensuse_Leap_15.1 gd * Up to
(excluding)
2.2.5-lp151.6.6.1
运行在以下环境
系统 oracle_8 gd * Up to
(excluding)
2.2.5-7.el8
运行在以下环境
系统 redhat_8 gd * Up to
(excluding)
2.2.5-7.el8
运行在以下环境
系统 suse_12 gd * Up to
(excluding)
2.1.0-24.17
运行在以下环境
系统 suse_12_SP4 gd * Up to
(excluding)
2.1.0-24.17.1
运行在以下环境
系统 suse_12_SP5 gd * Up to
(excluding)
2.1.0-24.17.1
运行在以下环境
系统 ubuntu_14.04 gd * Up to
(excluding)
2.1.0-3ubuntu0.11+esm1
运行在以下环境
系统 ubuntu_16.04 gd * Up to
(excluding)
2.1.1-4ubuntu0.16.04.12
运行在以下环境
系统 ubuntu_16.04.7_lts libgd2 * Up to
(excluding)
2.1.1-4ubuntu0.16.04.12
运行在以下环境
系统 ubuntu_18.04 gd * Up to
(excluding)
2.2.5-4ubuntu0.4
运行在以下环境
系统 ubuntu_18.04.5_lts libgd2 * Up to
(excluding)
2.2.5-4ubuntu0.4
运行在以下环境
系统 ubuntu_20.04 gd * Up to
(excluding)
2.2.5-5.2ubuntu1
运行在以下环境
系统 ubuntu_21.04 gd * Up to
(excluding)
2.2.5-5.2ubuntu1
运行在以下环境
系统 ubuntu_21.10 gd * Up to
(excluding)
2.2.5-5.2ubuntu1
运行在以下环境
系统 ubuntu_22.04 gd * Up to
(excluding)
2.2.5-5.2ubuntu1
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-476 空指针解引用
阿里云安全产品覆盖情况