低危 389-ds-base up to 1.3.7.10/1.3.8.8/1.4.0.16 Log File log__error_emergency 输入验证漏洞

CVE编号

CVE-2018-14624

利用情况

暂无

补丁情况

官方补丁

披露时间

2018-09-07 03:29:00
漏洞描述
389-ds-base through versions 1.3.7.10,1.3.8.8和1.4.0.16中发现了一个漏洞。在log__error_emergency()中重新打开日志文件时,未正确使用控制错误日志的锁。攻击者可能会向非常大的DN发送大量修改,这会导致slapd崩溃。
解决建议
目前厂商暂未发布修复措施解决此安全问题,建议使用此软件的用户随时关注厂商主页或参考网址以获取解决办法:
https://www.redhat.com/
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 fedoraproject 389_directory_server * Up to
(including)
1.3.7.10
运行在以下环境
应用 fedoraproject 389_directory_server * From
(including)
1.3.8.0
Up to
(including)
1.3.8.8
运行在以下环境
应用 fedoraproject 389_directory_server * From
(including)
1.4.0.0
Up to
(including)
1.4.0.16
2
运行在以下环境
系统 amazon_2 389-ds-base * Up to
(excluding)
1.3.7.5-28.amzn2.0.1
3
运行在以下环境
系统 opensuse_Leap_15.0 389-ds-base * Up to
(excluding)
1.4.0.3-lp150.3.3.1
4
运行在以下环境
系统 oracle_7 389-ds-base * Up to
(excluding)
1.3.7.5-28.el7_5
5
运行在以下环境
系统 centos_7 389-ds-base * Up to
(excluding)
1.3.7.5-28.el7_5
6
运行在以下环境
系统 amazon_AMI 389-ds-base * Up to
(excluding)
1.3.7.5-28.58.amzn1
7
运行在以下环境
系统 debian_9 389-ds-base * Up to
(excluding)
1.3.5.17-2
8
运行在以下环境
系统 debian_8 389-ds-base * Up to
(excluding)
1.3.3.5-4+deb8u1
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-20 输入验证不恰当
阿里云安全产品覆盖情况