低危 基于堆的缓冲区溢出通过“gf_getspec_req”RPC消息

CVE编号

CVE-2018-14653

利用情况

暂无

补丁情况

官方补丁

披露时间

2018-11-01
漏洞描述
通过版本4.1.4和3.12的Gluster文件系统容易受到'__server_getspec'函数中基于堆的缓冲区溢出的影响,通过'gf_getspec_req'RPC消息。远程经过身份验证的攻击者可能会利用此漏洞导致拒绝服务或其他潜在的未指定影响。<br>
解决建议
厂商已发布漏洞修复程序,请及时关注更新:
https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-14653
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 redhat gluster_storage * From
(including)
3.0.0
Up to
(including)
3.1.2
运行在以下环境
应用 redhat gluster_storage * From
(including)
4.1.0
Up to
(including)
4.1.4
运行在以下环境
系统 debian_8 glusterfs * Up to
(excluding)
3.5.2-2+deb8u4
运行在以下环境
系统 debian_9 glusterfs * Up to
(excluding)
3.8.8-1+deb9u1
运行在以下环境
系统 fedora_28 glusterfs * Up to
(excluding)
4.1.6-1.fc28
运行在以下环境
系统 fedora_29 glusterfs * Up to
(excluding)
5.1-1.fc29
阿里云评分
2.7
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    普通权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-122 堆缓冲区溢出
CWE-787 跨界内存写
阿里云安全产品覆盖情况