低危 FasterXML Jackson-databind 安全漏洞CVE-2018-14720

CVE编号

CVE-2018-14720

利用情况

暂无

补丁情况

官方补丁

披露时间

2019-01-03
漏洞描述
FasterXML Jackson是美国FasterXML公司的一款用于Java的数据处理工具。Jackson-databind是其中的一个具有数据绑定功能的组件。
FasterXML Jackson-databind 2.9.7之前的2.x版本中存在安全漏洞。远程攻击者可利用该漏洞执行XML外部实体注入攻击。

解决建议
升级至安全版本。
参考链接
https://access.redhat.com/errata/RHBA-2019:0959
https://access.redhat.com/errata/RHSA-2019:0782
https://access.redhat.com/errata/RHSA-2019:1106
https://access.redhat.com/errata/RHSA-2019:1107
https://access.redhat.com/errata/RHSA-2019:1108
https://access.redhat.com/errata/RHSA-2019:1140
https://access.redhat.com/errata/RHSA-2019:1822
https://access.redhat.com/errata/RHSA-2019:1823
https://access.redhat.com/errata/RHSA-2019:2858
https://access.redhat.com/errata/RHSA-2019:3149
https://access.redhat.com/errata/RHSA-2019:3892
https://access.redhat.com/errata/RHSA-2019:4037
https://github.com/FasterXML/jackson-databind/commit/87d29af25e82a249ea15858e...
https://github.com/FasterXML/jackson-databind/issues/2097
https://github.com/FasterXML/jackson/wiki/Jackson-Release-2.9.7
https://lists.apache.org/thread.html/519eb0fd45642dcecd9ff74cb3e71c20a4753f7d...
https://lists.apache.org/thread.html/6a78f88716c3c57aa74ec05764a37ab3874769a3...
https://lists.apache.org/thread.html/82b01bfb6787097427ce97cec6a7127e93718bc0...
https://lists.apache.org/thread.html/b0656d359c7d40ec9f39c8cc61bca66802ef9a2a...
https://lists.apache.org/thread.html/ba973114605d936be276ee6ce09dfbdbf78aa56f...
https://lists.apache.org/thread.html/f9bc3e55f4e28d1dcd1a69aae6d53e609a758e34...
https://lists.apache.org/thread.html/ff8dcfe29377088ab655fda9d585dccd5b1f07fa...
https://lists.apache.org/thread.html/rf1bbc0ea4a9f014cf94df9a12a6477d24a27f52...
https://lists.debian.org/debian-lts-announce/2019/03/msg00005.html
https://seclists.org/bugtraq/2019/May/68
https://security.netapp.com/advisory/ntap-20190530-0003/
https://www.debian.org/security/2019/dsa-4452
https://www.oracle.com/security-alerts/cpuapr2020.html
https://www.oracle.com/technetwork/security-advisory/cpuapr2019-5072813.html
https://www.oracle.com/technetwork/security-advisory/cpujan2019-5072801.html
https://www.oracle.com/technetwork/security-advisory/cpujul2019-5072835.html
https://www.oracle.com/technetwork/security-advisory/cpuoct2019-5072832.html
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 fasterxml jackson-databind * From
(including)
2.6.0
Up to
(excluding)
2.6.7.2
运行在以下环境
应用 fasterxml jackson-databind * From
(including)
2.7.0
Up to
(excluding)
2.7.9.5
运行在以下环境
应用 fasterxml jackson-databind * From
(including)
2.8.0
Up to
(excluding)
2.8.11.3
运行在以下环境
应用 fasterxml jackson-databind * From
(including)
2.9.0
Up to
(excluding)
2.9.7
运行在以下环境
应用 fasterxml jackson-databind 2.7.0 -
运行在以下环境
应用 fasterxml jackson-databind 2.8.0 -
运行在以下环境
应用 fasterxml jackson-databind 2.9.0 -
运行在以下环境
应用 oracle banking_platform 2.5.0 -
运行在以下环境
应用 oracle banking_platform 2.6.0 -
运行在以下环境
应用 oracle banking_platform 2.6.1 -
运行在以下环境
应用 oracle banking_platform 2.6.2 -
运行在以下环境
应用 oracle communications_billing_and_revenue_management 12.0 -
运行在以下环境
应用 oracle communications_billing_and_revenue_management 7.5 -
运行在以下环境
应用 oracle enterprise_manager_for_virtualization 13.2.2 -
运行在以下环境
应用 oracle enterprise_manager_for_virtualization 13.2.3 -
运行在以下环境
应用 oracle enterprise_manager_for_virtualization 13.3.1 -
运行在以下环境
应用 oracle financial_services_analytical_applications_infrastructure 8.0.2 -
运行在以下环境
应用 oracle financial_services_analytical_applications_infrastructure 8.0.3 -
运行在以下环境
应用 oracle financial_services_analytical_applications_infrastructure 8.0.4 -
运行在以下环境
应用 oracle financial_services_analytical_applications_infrastructure 8.0.5 -
运行在以下环境
应用 oracle financial_services_analytical_applications_infrastructure 8.0.6 -
运行在以下环境
应用 oracle financial_services_analytical_applications_infrastructure 8.0.7 -
运行在以下环境
应用 oracle jdeveloper 12.1.3.0.0 -
运行在以下环境
应用 oracle jdeveloper 12.2.1.3.0 -
运行在以下环境
应用 oracle primavera_unifier * From
(including)
17.1
Up to
(including)
17.12
运行在以下环境
应用 oracle primavera_unifier 16.1 -
运行在以下环境
应用 oracle primavera_unifier 16.2 -
运行在以下环境
应用 oracle primavera_unifier 18.8 -
运行在以下环境
应用 oracle retail_merchandising_system 15.0 -
运行在以下环境
应用 oracle retail_merchandising_system 16.0 -
运行在以下环境
应用 oracle webcenter_portal 12.2.1.3.0 -
运行在以下环境
应用 redhat jboss_enterprise_application_platform 7.2.0 -
运行在以下环境
应用 redhat openshift_container_platform 3.11 -
运行在以下环境
系统 debian debian_linux 8.0 -
运行在以下环境
系统 debian debian_linux 9.0 -
运行在以下环境
系统 debian_8 jackson-databind * Up to
(excluding)
2.4.2-2+deb8u2
运行在以下环境
系统 debian_9 jackson-databind * Up to
(excluding)
2.8.6-1+deb9u5
运行在以下环境
系统 fedora_29 jackson-databind * Up to
(excluding)
1.61-1.fc29
运行在以下环境
系统 ubuntu_18.04.5_lts jackson-databind * Up to
(excluding)
2.9.8-1
运行在以下环境
系统 ubuntu_18.04_lts jackson-databind * Up to
(excluding)
2.9.8-1
阿里云评分
3.6
  • 攻击路径
    远程
  • 攻击复杂度
    容易
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    传输被破坏
  • 服务器危害
    无影响
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-502 可信数据的反序列化
CWE-611 XML外部实体引用的不恰当限制(XXE)
阿里云安全产品覆盖情况