中危 SYSTEMD <= 239 UNIT_DESERIALIZE 反序列化漏洞

CVE编号

CVE-2018-15686

利用情况

POC 已公开

补丁情况

官方补丁

披露时间

2018-10-27
漏洞描述
systemd的unit_deserialize中的漏洞允许攻击者通过NotifyAccess在系统重新执行期间提供任意状态。这可能会用于不正确地影响系统执行,并可能导致root权限升级。受影响的版本是systemd版本,最高可达239。

解决建议
升级至安全版本。
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 freedesktop systemd * Up to
(including)
239
运行在以下环境
系统 amazon_2 systemd * Up to
(excluding)
219-78.amzn2.0.14
运行在以下环境
系统 canonical ubuntu_linux 16.04 -
运行在以下环境
系统 canonical ubuntu_linux 18.04 -
运行在以下环境
系统 canonical ubuntu_linux 18.10 -
运行在以下环境
系统 debian debian_linux 8.0 -
运行在以下环境
系统 debian_8 systemd * Up to
(excluding)
215-17+deb8u8
运行在以下环境
系统 debian_9 systemd * Up to
(excluding)
232-25+deb9u10
运行在以下环境
系统 fedora_28 systemd * Up to
(excluding)
238-10.git438ac26.fc28
运行在以下环境
系统 fedora_29 systemd * Up to
(excluding)
239-6.git9f3aed1.fc29
运行在以下环境
系统 opensuse_Leap_15.0 systemd * Up to
(excluding)
234-lp150.20.9.1
运行在以下环境
系统 opensuse_Leap_42.3 systemd * Up to
(excluding)
228-62.1
运行在以下环境
系统 oracle linux_7 systemd * Up to
(excluding)
219-67.0.1.el7
运行在以下环境
系统 oracle_7 systemd * Up to
(excluding)
219-67.0.1.el7
运行在以下环境
系统 redhat_7 libgudev1 * Up to
(excluding)
0:219-67.el7
运行在以下环境
系统 sles_12 libsystemd0-228 * Up to
(excluding)
150.53
运行在以下环境
系统 sles_12_SP3 systemd * Up to
(excluding)
228-150.53.3
运行在以下环境
系统 sles_12_SP4 systemd * Up to
(excluding)
228-150.53.3
运行在以下环境
系统 suse_12 libsystemd0-228 * Up to
(excluding)
150.53
运行在以下环境
系统 suse_12_SP3 systemd * Up to
(excluding)
228-150.53.3
运行在以下环境
系统 suse_12_SP4 systemd * Up to
(excluding)
228-150.53.3
运行在以下环境
系统 ubuntu_16.04 systemd * Up to
(excluding)
229-4ubuntu21.8
运行在以下环境
系统 ubuntu_16.04.7_lts systemd * Up to
(excluding)
229-4ubuntu21.8
运行在以下环境
系统 ubuntu_16.04_lts systemd * Up to
(excluding)
229-4ubuntu21.8
运行在以下环境
系统 ubuntu_18.04 systemd * Up to
(excluding)
237-3ubuntu10.6
运行在以下环境
系统 ubuntu_18.04.5_lts systemd * Up to
(excluding)
237-3ubuntu10.6
运行在以下环境
系统 ubuntu_18.04_lts systemd * Up to
(excluding)
237-3ubuntu10.6
运行在以下环境
系统 ubuntu_18.10 systemd * Up to
(excluding)
239-7ubuntu10.3
阿里云评分
5.9
  • 攻击路径
    本地
  • 攻击复杂度
    困难
  • 权限要求
    普通权限
  • 影响范围
    全局影响
  • EXP成熟度
    POC 已公开
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    服务器失陷
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-502 可信数据的反序列化
阿里云安全产品覆盖情况