低危 GD Graphics Library 资源管理错误漏洞

CVE编号

CVE-2018-15879

利用情况

暂无

补丁情况

官方补丁

披露时间

2019-06-21
漏洞描述
GD Graphics Library(libgd或libgd2)是美国Thomas Boutell软件开发者的一个开源的用于动态创建图像的库。该产品支持创建图表、图形和缩略图等。
GD Graphics Library 2.2.5及之前版本中的‘gdImageBmpPt’参数存在资源管理错误漏洞。该漏洞源于网络系统或产品对系统资源(如内存、磁盘空间、文件等)的管理不当。

解决建议
目前厂商已发布升级补丁以修复漏洞,补丁获取链接:
https://github.com/libgd/libgd/issues/447
参考链接
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
系统 ubuntu_14.04.6_lts libgd2 * Up to
(excluding)
2.1.0-3ubuntu0.10
运行在以下环境
系统 ubuntu_16.04.7_lts libgd2 * Up to
(excluding)
2.1.1-4ubuntu0.16.04.10
运行在以下环境
系统 ubuntu_18.04.5_lts libgd2 * Up to
(excluding)
2.2.5-4ubuntu0.2
运行在以下环境
系统 ubuntu_18.10 libgd2 * Up to
(excluding)
2.2.5-4ubuntu1
阿里云评分
2.3
  • 攻击路径
    本地
  • 攻击复杂度
    困难
  • 权限要求
    普通权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    -
CWE-ID 漏洞类型
阿里云安全产品覆盖情况