低危 信息使用GlobalId通过反序列化进行曝光

CVE编号

CVE-2018-16476

利用情况

暂无

补丁情况

官方补丁

披露时间

2018-12-01
漏洞描述
Active Job版本中的Active Job versions &gt;= 4.2.0允许攻击者创建用户输入,这可能导致Active Job使用GlobalId对其进行反序列化,并允许他们访问不应具有的信息。<br><br>
解决建议
建议您更新当前系统或软件至最新版,完成漏洞的修复。
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 redhat cloudforms 4.6 -
运行在以下环境
应用 rubyonrails rails * From
(including)
4.2.0
Up to
(excluding)
4.2.11
运行在以下环境
应用 rubyonrails rails * From
(including)
5.0.0
Up to
(excluding)
5.0.7.1
运行在以下环境
应用 rubyonrails rails * From
(including)
5.1.0
Up to
(excluding)
5.1.6.1
运行在以下环境
应用 rubyonrails rails * From
(including)
5.2.0
Up to
(excluding)
5.2.1.1
运行在以下环境
系统 debian_9 rails * Up to
(excluding)
2:4.2.7.1-1+deb9u1
运行在以下环境
系统 fedora_28 rails * Up to
(excluding)
5.1.5-2.fc28
运行在以下环境
系统 fedora_29 rails * Up to
(excluding)
5.2.1-2.fc29
运行在以下环境
系统 opensuse_Leap_15.0 rails * Up to
(excluding)
5.1.4-lp150.2.3.1
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-502 可信数据的反序列化
阿里云安全产品覆盖情况