低危 nginx up to 1.14.0/1.15.5 HTTP2 CPU Exhaustion 拒绝服务漏洞

CVE编号

CVE-2018-16844

利用情况

暂无

补丁情况

官方补丁

披露时间

2018-11-08
漏洞描述
版本1.15.6和1.14.1之前的nginx在HTTP / 2的实现中存在漏洞,可能允许过多的CPU使用。如果在配置文件中使用'listen'指令的'http2'选项,则此问题会影响使用ngx_http_v2_module编译的nginx(默认情况下不编译)。

解决建议
厂商已发布漏洞修复程序,请及时关注更新:
http://nginx.org/
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 nginx nginx * From
(including)
1.15.0
Up to
(excluding)
1.15.6
运行在以下环境
应用 nginx nginx * From
(including)
1.9.5
Up to
(excluding)
1.14.1
运行在以下环境
系统 alpine_3.10 nginx * Up to
(excluding)
1.14.1-r0
运行在以下环境
系统 alpine_3.11 nginx * Up to
(excluding)
1.14.1-r0
运行在以下环境
系统 alpine_3.12 nginx * Up to
(excluding)
1.14.1-r0
运行在以下环境
系统 alpine_3.13 nginx * Up to
(excluding)
1.14.1-r0
运行在以下环境
系统 alpine_3.14 nginx * Up to
(excluding)
1.14.1-r0
运行在以下环境
系统 alpine_3.15 nginx * Up to
(excluding)
1.14.1-r0
运行在以下环境
系统 alpine_3.16 nginx * Up to
(excluding)
1.14.1-r0
运行在以下环境
系统 alpine_3.6 nginx * Up to
(excluding)
1.12.2-r2
运行在以下环境
系统 alpine_3.7 nginx * Up to
(excluding)
1.12.1-r4
运行在以下环境
系统 alpine_3.8 nginx * Up to
(excluding)
1.14.1-r0
运行在以下环境
系统 alpine_3.9 nginx * Up to
(excluding)
1.14.1-r0
运行在以下环境
系统 alpine_edge nginx * Up to
(excluding)
1.14.1-r0
运行在以下环境
系统 amazon_AMI nginx * Up to
(excluding)
1.14.1-2.34.amzn1
运行在以下环境
系统 debian_9 nginx * Up to
(excluding)
1.10.3-1+deb9u2
运行在以下环境
系统 fedora_27 nginx * Up to
(excluding)
1.14.1-1.fc27
运行在以下环境
系统 fedora_28 nginx * Up to
(excluding)
1.14.1-1.fc28
运行在以下环境
系统 fedora_29 nginx * Up to
(excluding)
1.14.1-2.fc29
运行在以下环境
系统 opensuse_Leap_15.0 nginx * Up to
(excluding)
1.14.2-16.1
运行在以下环境
系统 opensuse_Leap_15.1 nginx * Up to
(excluding)
1.14.2-lp151.4.3.1
运行在以下环境
系统 opensuse_Leap_42.3 nginx * Up to
(excluding)
1.14.2-16.1
运行在以下环境
系统 oracle_8 nginx * Up to
(excluding)
1.16.1-1.0.1.module+el8.3.0+7892+37ea59a5.1
运行在以下环境
系统 ubuntu_16.04 nginx * Up to
(excluding)
1.10.3-0ubuntu0.16.04.3
运行在以下环境
系统 ubuntu_16.04.7_lts nginx * Up to
(excluding)
1.10.3-0ubuntu0.16.04.3
运行在以下环境
系统 ubuntu_18.04 nginx * Up to
(excluding)
1.14.0-0ubuntu1.2
运行在以下环境
系统 ubuntu_18.04.5_lts nginx * Up to
(excluding)
1.14.0-0ubuntu1.2
运行在以下环境
系统 ubuntu_18.10 nginx * Up to
(excluding)
1.15.5-0ubuntu2.1
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-400 未加控制的资源消耗(资源穷尽)
阿里云安全产品覆盖情况