低危 解析精心制作的syslog消息时读取越界

CVE编号

CVE-2018-16866

利用情况

暂无

补丁情况

官方补丁

披露时间

2019-01-12
漏洞描述
在systemd-journald中以分解以冒号':'结尾的日志消息的方式发现了越界读取。本地攻击者可以利用此漏洞来披露进程内存数据。版本v221到v239的版本容易受到攻击。

解决建议
建议您更新当前系统或软件至最新版,完成漏洞的修复。
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 freedesktop systemd * From
(including)
221
Up to
(including)
239
运行在以下环境
应用 netapp active_iq_performance_analytics_services - -
运行在以下环境
应用 netapp element_software * -
运行在以下环境
系统 amazon_2 systemd * Up to
(excluding)
219-57.amzn2.0.7
运行在以下环境
系统 debian_9 systemd * Up to
(excluding)
232-25+deb9u7
运行在以下环境
系统 fedora_28 systemd * Up to
(excluding)
238-11.gita76ee90.fc28
运行在以下环境
系统 fedora_29 systemd * Up to
(excluding)
239-8.gite339eae.fc29
运行在以下环境
系统 opensuse_Leap_15.0 systemd * Up to
(excluding)
234-lp150.20.12.1
运行在以下环境
系统 opensuse_Leap_42.3 systemd * Up to
(excluding)
228-65.1
运行在以下环境
系统 oracle_7 systemd * Up to
(excluding)
219-67.0.1.el7
运行在以下环境
系统 suse_12_SP3 systemd * Up to
(excluding)
228-150.58.1
运行在以下环境
系统 suse_12_SP4 systemd * Up to
(excluding)
228-150.58.1
运行在以下环境
系统 ubuntu_16.04 systemd * Up to
(excluding)
229-4ubuntu21.15
运行在以下环境
系统 ubuntu_18.04 systemd * Up to
(excluding)
237-3ubuntu10.11
阿里云评分
2.6
  • 攻击路径
    本地
  • 攻击复杂度
    复杂
  • 权限要求
    普通权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-125 跨界内存读
阿里云安全产品覆盖情况