低危 systemd up to v236 PIDFile File 拒绝服务漏洞

CVE编号

CVE-2018-16888

利用情况

暂无

补丁情况

官方补丁

披露时间

2019-01-15
漏洞描述
发现systemd在使用它来杀死进程之前没有正确检查PIDFile文件的内容。当从非特权用户运行服务时(例如,在服务文件中设置用户字段),能够写入所提及服务的PID文件的本地攻击者可能利用此缺陷欺骗systemd杀死其他服务和/或特权流程。 v237之前的版本容易受到攻击。<br>
解决建议
建议您更新当前系统或软件至最新版,完成漏洞的修复。
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 freedesktop systemd * Up to
(excluding)
237
运行在以下环境
应用 netapp active_iq_performance_analytics_services - -
运行在以下环境
应用 netapp element_software - -
运行在以下环境
系统 debian_9 systemd * Up to
(excluding)
232-25+deb9u12
运行在以下环境
系统 oracle_7 systemd * Up to
(excluding)
219-67.0.1.el7
运行在以下环境
系统 ubuntu_16.04 systemd * Up to
(excluding)
229-4ubuntu21.27
阿里云评分
2.3
  • 攻击路径
    本地
  • 攻击复杂度
    困难
  • 权限要求
    普通权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-20 输入验证不恰当
CWE-732 关键资源的不正确权限授予
阿里云安全产品覆盖情况