低危 Ceph 至 13.2.4 Debug Logging Password 信息泄漏漏洞

CVE编号

CVE-2018-16889

利用情况

暂无

补丁情况

官方补丁

披露时间

2019-01-29
漏洞描述
在v4 auth的调试日志记录中,Ceph没有正确清理加密密钥。这导致通过明文泄漏日志文件中的加密密钥信息。高达v13.2.4的版本容易受到攻击。<br>
解决建议
厂商已发布了漏洞修复程序,请及时关注更新:
https://github.com/ceph/ceph/pull/25881/commits
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 redhat ceph * Up to
(including)
13.2.4
运行在以下环境
系统 debian_9 ceph * Up to
(including)
10.2.11-2
运行在以下环境
系统 fedora_29 ceph * Up to
(excluding)
12.2.11-1.fc29
运行在以下环境
系统 opensuse_Leap_42.3 ceph * Up to
(excluding)
12.2.10
运行在以下环境
系统 suse_12 ceph * Up to
(excluding)
12.2.10+git.1549630712.bb089269ea-2.27
运行在以下环境
系统 suse_12_SP3 ceph * Up to
(excluding)
12.2.10
运行在以下环境
系统 suse_12_SP4 ceph * Up to
(excluding)
12.2.10
运行在以下环境
系统 ubuntu_16.04 ceph * Up to
(excluding)
10.2.11-0ubuntu0.16.04.2
运行在以下环境
系统 ubuntu_16.04.7_lts ceph * Up to
(excluding)
10.2.11-0ubuntu0.16.04.2
运行在以下环境
系统 ubuntu_18.04 ceph * Up to
(excluding)
12.2.11-0ubuntu0.18.04.1
运行在以下环境
系统 ubuntu_18.04.5_lts ceph * Up to
(excluding)
12.2.11-0ubuntu0.18.04.1
运行在以下环境
系统 ubuntu_18.10 ceph * Up to
(excluding)
13.2.4+dfsg1-0ubuntu0.18.10.2
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-20 输入验证不恰当
CWE-200 信息暴露
CWE-312 敏感数据的明文存储
阿里云安全产品覆盖情况