IBM DB2缓冲区溢出漏洞(CNVD-2018-20058)

CVE编号

CVE-2018-1710

利用情况

暂无

补丁情况

N/A

披露时间

2018-09-22
漏洞描述
IBM DB2是美国IBM公司的一套关系型数据库管理系统。该系统的执行环境主要有UNIX、Linux、IBM i、z/OS以及Windows服务器版本。

IBM DB2(包括DB2 Connect Server)中的‘db2licm’工具存在缓冲区溢出漏洞。攻击者可利用该漏洞执行任意代码。
解决建议
目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:
https://www-01.ibm.com/support/docview.wss?uid=ibm10729981
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 ibm db2 10.1 -
运行在以下环境
应用 ibm db2 10.5 -
运行在以下环境
应用 ibm db2 11.1 -
运行在以下环境
系统 alibaba_cloud_linux_2.1903 tiff * Up to
(excluding)
4.0.3-32.1.al7
运行在以下环境
系统 alpine_3.10 tiff * Up to
(excluding)
4.0.9-r8
运行在以下环境
系统 alpine_3.11 tiff * Up to
(excluding)
4.0.9-r8
运行在以下环境
系统 alpine_3.12 tiff * Up to
(excluding)
4.0.9-r8
运行在以下环境
系统 alpine_3.13 tiff * Up to
(excluding)
4.0.9-r8
运行在以下环境
系统 alpine_3.5 tiff * Up to
(excluding)
4.0.9-r6
运行在以下环境
系统 alpine_3.6 tiff * Up to
(excluding)
4.0.9-r6
运行在以下环境
系统 alpine_3.7 tiff * Up to
(excluding)
4.0.9-r6
运行在以下环境
系统 alpine_3.8 tiff * Up to
(excluding)
4.0.9-r7
运行在以下环境
系统 alpine_3.9 tiff * Up to
(excluding)
4.0.9-r8
运行在以下环境
系统 alpine_edge tiff * Up to
(excluding)
4.0.9-r8
运行在以下环境
系统 amazon_2 tiff * Up to
(excluding)
4.0.3-32.amzn2
运行在以下环境
系统 amazon_AMI tiff * Up to
(excluding)
4.0.3-32.34.amzn1
运行在以下环境
系统 debian_8 tiff * Up to
(excluding)
4.0.3-12.3+deb8u10
运行在以下环境
系统 debian_9 tiff * Up to
(excluding)
4.0.8-2+deb9u4
运行在以下环境
系统 fedora_28 tiff * Up to
(excluding)
4.0.9-13.fc28
运行在以下环境
系统 fedora_29 tiff * Up to
(excluding)
4.0.9-13.fc29
运行在以下环境
系统 opensuse_Leap_15.0 tiff * Up to
(excluding)
4.0.9-lp150.4.6.1
运行在以下环境
系统 opensuse_Leap_42.3 tiff * Up to
(excluding)
4.0.9-37.1
运行在以下环境
系统 oracle_7 tiff * Up to
(excluding)
4.0.3-32.el7
运行在以下环境
系统 redhat_7 libtiff * Up to
(excluding)
0:4.0.3-32.el7
运行在以下环境
系统 suse_11_SP4 tiff * Up to
(excluding)
3.8.2-141.169.19.1
运行在以下环境
系统 suse_12 libtiff5 * Up to
(excluding)
4.0.9-44.24
运行在以下环境
系统 suse_12_SP3 tiff * Up to
(excluding)
4.0.9-44.24.1
运行在以下环境
系统 ubuntu_14.04.6_lts tiff * Up to
(excluding)
4.0.3-7ubuntu0.10
运行在以下环境
系统 ubuntu_16.04.7_lts tiff * Up to
(excluding)
4.0.6-1ubuntu0.5
运行在以下环境
系统 ubuntu_18.04.5_lts tiff * Up to
(excluding)
4.0.9-5ubuntu0.1
运行在以下环境
系统 ubuntu_18.10 tiff * Up to
(excluding)
4.0.9-6ubuntu0.1
CVSS3评分
7.8
  • 攻击路径
    本地
  • 攻击复杂度
  • 权限要求
  • 影响范围
    未更改
  • 用户交互
  • 可用性
  • 保密性
  • 完整性
CWE-ID 漏洞类型
CWE-119 内存缓冲区边界内操作的限制不恰当
阿里云安全产品覆盖情况