低危 越界访问拒绝服务漏洞

CVE编号

CVE-2018-17101

利用情况

暂无

补丁情况

官方补丁

披露时间

2018-09-17
漏洞描述
在LibTIFF 4.0.9中发现了一个问题。在tools / tiff2bw.c和tools / pal2rgb.c中的cpTags中有两个越界写入,这可能导致拒绝服务(应用程序崩溃)或者可能通过精心设计的图像文件产生未指定的其他影响。

解决建议
建议您更新当前系统或软件至最新版,完成漏洞的修复。
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 libtiff libtiff 4.0.9 -
运行在以下环境
系统 alibaba_cloud_linux_2.1903 tiff * Up to
(excluding)
4.0.3-32.1.al7
运行在以下环境
系统 alpine_3.10 tiff * Up to
(excluding)
4.0.9-r8
运行在以下环境
系统 alpine_3.11 tiff * Up to
(excluding)
4.0.9-r8
运行在以下环境
系统 alpine_3.12 tiff * Up to
(excluding)
4.0.9-r8
运行在以下环境
系统 alpine_3.13 tiff * Up to
(excluding)
4.0.9-r8
运行在以下环境
系统 alpine_3.14 tiff * Up to
(excluding)
4.0.9-r8
运行在以下环境
系统 alpine_3.15 tiff * Up to
(excluding)
4.0.9-r8
运行在以下环境
系统 alpine_3.16 tiff * Up to
(excluding)
4.0.9-r8
运行在以下环境
系统 alpine_3.5 tiff * Up to
(excluding)
4.0.9-r6
运行在以下环境
系统 alpine_3.6 tiff * Up to
(excluding)
4.0.9-r6
运行在以下环境
系统 alpine_3.7 tiff * Up to
(excluding)
4.0.9-r6
运行在以下环境
系统 alpine_3.8 tiff * Up to
(excluding)
4.0.9-r7
运行在以下环境
系统 alpine_3.9 tiff * Up to
(excluding)
4.0.9-r8
运行在以下环境
系统 alpine_edge tiff * Up to
(excluding)
4.0.9-r8
运行在以下环境
系统 amazon linux_2 tiff * Up to
(excluding)
4.0.3-32.amzn2
运行在以下环境
系统 amazon linux_AMI tiff * Up to
(excluding)
4.0.3-32.34.amzn1
运行在以下环境
系统 amazon_2 tiff * Up to
(excluding)
4.0.3-32.amzn2
运行在以下环境
系统 amazon_AMI tiff * Up to
(excluding)
4.0.3-32.34.amzn1
运行在以下环境
系统 canonical ubuntu_linux 14.04 -
运行在以下环境
系统 canonical ubuntu_linux 16.04 -
运行在以下环境
系统 canonical ubuntu_linux 18.04 -
运行在以下环境
系统 canonical ubuntu_linux 18.10 -
运行在以下环境
系统 debian debian_linux 8.0 -
运行在以下环境
系统 debian debian_linux 9.0 -
运行在以下环境
系统 debian_8 tiff * Up to
(excluding)
4.0.3-12.3+deb8u10
运行在以下环境
系统 debian_9 tiff * Up to
(excluding)
4.0.8-2+deb9u4
运行在以下环境
系统 fedora_28 tiff * Up to
(excluding)
4.0.9-13.fc28
运行在以下环境
系统 fedora_29 tiff * Up to
(excluding)
4.0.9-13.fc29
运行在以下环境
系统 opensuse_Leap_15.0 tiff * Up to
(excluding)
4.0.9-lp150.4.6.1
运行在以下环境
系统 opensuse_Leap_42.3 tiff * Up to
(excluding)
4.0.9-37.1
运行在以下环境
系统 oracle linux_7 tiff * Up to
(excluding)
4.0.3-32.el7
运行在以下环境
系统 oracle_7 tiff * Up to
(excluding)
4.0.3-32.el7
运行在以下环境
系统 redhat_7 libtiff * Up to
(excluding)
0:4.0.3-32.el7
运行在以下环境
系统 sles_11_SP4 tiff * Up to
(excluding)
3.8.2-141.169.19.1
运行在以下环境
系统 sles_12 libtiff5 * Up to
(excluding)
4.0.9-44.24
运行在以下环境
系统 sles_12_SP3 tiff * Up to
(excluding)
4.0.9-44.24.1
运行在以下环境
系统 suse_11_SP4 tiff * Up to
(excluding)
3.8.2-141.169.19.1
运行在以下环境
系统 suse_12 libtiff5 * Up to
(excluding)
4.0.9-44.24
运行在以下环境
系统 suse_12_SP3 tiff * Up to
(excluding)
4.0.9-44.24.1
运行在以下环境
系统 ubuntu_14.04 tiff * Up to
(excluding)
4.0.3-7ubuntu0.10
运行在以下环境
系统 ubuntu_14.04.6_lts tiff * Up to
(excluding)
4.0.3-7ubuntu0.10
运行在以下环境
系统 ubuntu_14.04_lts tiff * Up to
(excluding)
4.0.3-7ubuntu0.10
运行在以下环境
系统 ubuntu_16.04 tiff * Up to
(excluding)
4.0.6-1ubuntu0.5
运行在以下环境
系统 ubuntu_16.04.7_lts tiff * Up to
(excluding)
4.0.6-1ubuntu0.5
运行在以下环境
系统 ubuntu_16.04_lts tiff * Up to
(excluding)
4.0.6-1ubuntu0.5
运行在以下环境
系统 ubuntu_18.04 tiff * Up to
(excluding)
4.0.9-5ubuntu0.1
运行在以下环境
系统 ubuntu_18.04.5_lts tiff * Up to
(excluding)
4.0.9-5ubuntu0.1
运行在以下环境
系统 ubuntu_18.04_lts tiff * Up to
(excluding)
4.0.9-5ubuntu0.1
运行在以下环境
系统 ubuntu_18.10 tiff * Up to
(excluding)
4.0.9-6ubuntu0.1
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-787 跨界内存写
阿里云安全产品覆盖情况