高危 Linux kernel mm/vmacache.c 溢出漏洞可导致 Local Privilege Escalation

CVE编号

CVE-2018-17182

利用情况

EXP 已公开

补丁情况

官方补丁

披露时间

2018-09-19
该漏洞EXP已公开传播,漏洞利用成本极低,建议您立即关注并修复。
漏洞描述
 Linux kernel through 4.18.8中发现了一个问题。 mm / vmacache.c中的vmacache_flush_all函数错误处理序列号溢出。攻击者可以通过某些线程创建,映射,取消映射,失效和解除引用操作来触发UAF并可能获得特权)。

解决建议
1. 使用对应发行版的包管理器对内核进行升级。
2. 下载新版Linux内核,手动编译并安装内核。
安装完毕后需要对机器进行重启。
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 netapp active_iq_performance_analytics_services - -
运行在以下环境
应用 netapp element_software - -
运行在以下环境
系统 canonical ubuntu_linux 14.04 -
运行在以下环境
系统 canonical ubuntu_linux 16.04 -
运行在以下环境
系统 canonical ubuntu_linux 18.04 -
运行在以下环境
系统 debian debian_linux 8.0 -
运行在以下环境
系统 debian debian_linux 9.0 -
运行在以下环境
系统 linux linux_kernel * Up to
(including)
4.18.8
运行在以下环境
系统 sles_12 kernel-default-extra * Up to
(excluding)
4.12.14-94.41
运行在以下环境
系统 ubuntu_14.04_lts linux-aws * Up to
(excluding)
4.4.0-1031.34
运行在以下环境
系统 ubuntu_16.04_lts linux * Up to
(excluding)
4.4.0-137.163
运行在以下环境
系统 ubuntu_18.04_lts linux * Up to
(excluding)
4.15.0-36.39
运行在以下环境
系统 ubuntu_18.10 linux * Up to
(excluding)
4.18.0-9.10
阿里云评分
8.4
  • 攻击路径
    本地
  • 攻击复杂度
    容易
  • 权限要求
    无需权限
  • 影响范围
    全局影响
  • EXP成熟度
    EXP 已公开
  • 补丁情况
    官方补丁
  • 数据保密性
    数据泄露
  • 数据完整性
    无影响
  • 服务器危害
    服务器失陷
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-416 释放后使用
阿里云安全产品覆盖情况