低危 AdPlug 2.3.1 emuopl.cpp CEmuopl 拒绝服务漏洞

CVE编号

CVE-2018-17825

利用情况

暂无

补丁情况

官方补丁

披露时间

2018-10-01 21:29:00
漏洞描述
在AdPlug 2.3.1中发现了一个问题。由于destructor的两个OPLDestroy调用,emuopl.cpp中的CEmuopl类中存在多个双重漏洞,每个漏洞都释放TL_TABLE,SIN_TABLE,AMS_TABLE和VIB_TABLE。
解决建议
厂商尚未提供漏洞修复方案,请关注厂商主页更新:
https://github.com/adplug/adplug/issues/67
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 adplug_project adplug 2.3.1 -
2
运行在以下环境
系统 debian_8 adplug * Up to
(excluding)
2.2.1+dfsg3-0.1+deb8u1
3
运行在以下环境
系统 debian_9 adplug * Up to
(excluding)
2.2.1+dfsg3-0.4
4
运行在以下环境
系统 fedora_EPEL_7 adplug * Up to
(excluding)
2.3.3-1.el7
5
运行在以下环境
系统 fedora_29 adplug * Up to
(excluding)
2.2.1-7.fc29
6
运行在以下环境
系统 fedora_EPEL_8 adplug * Up to
(excluding)
2.3.3-1.el8
7
运行在以下环境
系统 fedora_33 adplug * Up to
(excluding)
2.3.3-1.fc33
8
运行在以下环境
系统 fedora_32 adplug * Up to
(excluding)
2.3.3-1.fc32
9
运行在以下环境
系统 fedora_28 adplug * Up to
(excluding)
2.2.1-7.fc28
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-415 双重释放
阿里云安全产品覆盖情况