低危 缓冲区溢出漏洞

CVE编号

CVE-2018-17958

利用情况

暂无

补丁情况

官方补丁

披露时间

2018-10-10
漏洞描述
Qemu在hw / net / rtl8139.c中的rtl8139_do_receive中有缓冲区溢出,因为使用了不正确的整数数据类型。

解决建议
厂商已发布了漏洞修复程序,请及时关注更新:
https://www.qemu.org/
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 qemu qemu * Up to
(including)
3.0.1
运行在以下环境
应用 redhat virtualization 4.0 -
运行在以下环境
应用 redhat virtualization_manager 4.3 -
运行在以下环境
系统 debian_10 qemu * Up to
(excluding)
3.1+dfsg-1
运行在以下环境
系统 debian_11 qemu * Up to
(excluding)
3.1+dfsg-1
运行在以下环境
系统 debian_12 qemu * Up to
(excluding)
3.1+dfsg-1
运行在以下环境
系统 fedora_29 qemu-block-rbd * Up to
(excluding)
3.0.0-2.fc29
运行在以下环境
系统 opensuse_Leap_15.0 qemu * Up to
(excluding)
2.11.2-lp150.7.12.1
运行在以下环境
系统 opensuse_Leap_42.3 qemu * Up to
(excluding)
2.9.1-50.1
运行在以下环境
系统 oracle_7 qemu * Up to
(excluding)
2.9.0-17.el7
运行在以下环境
系统 suse_11_SP4 kvm * Up to
(excluding)
1.4.2-60.18.2
运行在以下环境
系统 suse_12_SP3 + * Up to
(excluding)
2.9.1-6.22.3
运行在以下环境
系统 suse_12_SP4 + * Up to
(excluding)
2.11.2-5.5.1
运行在以下环境
系统 ubuntu_14.04 qemu * Up to
(excluding)
2.0.0+dfsg-2ubuntu1.44
运行在以下环境
系统 ubuntu_16.04 qemu * Up to
(excluding)
2.5+dfsg-5ubuntu10.33
运行在以下环境
系统 ubuntu_18.04 qemu * Up to
(excluding)
2.11+dfsg-1ubuntu7.8
运行在以下环境
系统 ubuntu_20.04 qemu * Up to
(excluding)
2.12+dfsg-3ubuntu9
运行在以下环境
系统 ubuntu_21.04 qemu * Up to
(excluding)
2.12+dfsg-3ubuntu9
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-190 整数溢出或超界折返
阿里云安全产品覆盖情况