低危 基于堆的缓冲区溢出

CVE编号

CVE-2018-18314

利用情况

暂无

补丁情况

官方补丁

披露时间

2018-12-08
漏洞描述
5.26.3之前的Perl通过精心设计的正则表达式缓冲区溢出,该表达式触发无效的写入操作。

解决建议
厂商已发布了漏洞修复程序,请及时关注更新:
https://metacpan.org/changes/release/SHAY/perl-5.26.3
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 netapp e-series_santricity_os_controller * From
(including)
11.0
Up to
(including)
11.40
运行在以下环境
应用 netapp snapcenter - -
运行在以下环境
应用 netapp snapdrive - -
运行在以下环境
应用 netapp snap_creator_framework - -
运行在以下环境
应用 perl perl * Up to
(excluding)
5.26.3
运行在以下环境
系统 alpine_3.10 perl * Up to
(excluding)
5.26.3-r0
运行在以下环境
系统 alpine_3.11 perl * Up to
(excluding)
5.26.3-r0
运行在以下环境
系统 alpine_3.12 perl * Up to
(excluding)
5.26.3-r0
运行在以下环境
系统 alpine_3.13 perl * Up to
(excluding)
5.26.3-r0
运行在以下环境
系统 alpine_3.14 perl * Up to
(excluding)
5.26.3-r0
运行在以下环境
系统 alpine_3.15 perl * Up to
(excluding)
5.26.3-r0
运行在以下环境
系统 alpine_3.16 perl * Up to
(excluding)
5.26.3-r0
运行在以下环境
系统 alpine_3.17 perl * Up to
(excluding)
5.26.3-r0
运行在以下环境
系统 alpine_3.18 perl * Up to
(excluding)
5.26.3-r0
运行在以下环境
系统 alpine_3.6 perl * Up to
(excluding)
5.24.4-r2
运行在以下环境
系统 alpine_3.7 perl * Up to
(excluding)
5.26.3-r0
运行在以下环境
系统 alpine_3.8 perl * Up to
(excluding)
5.26.3-r0
运行在以下环境
系统 alpine_3.9 perl * Up to
(excluding)
5.26.3-r0
运行在以下环境
系统 alpine_edge perl * Up to
(excluding)
5.26.3-r0
运行在以下环境
系统 debian_10 perl * Up to
(excluding)
5.28.0-3
运行在以下环境
系统 debian_11 perl * Up to
(excluding)
5.28.0-3
运行在以下环境
系统 debian_12 perl * Up to
(excluding)
5.28.0-3
运行在以下环境
系统 debian_sid perl * Up to
(excluding)
5.28.0-3
运行在以下环境
系统 fedora_28 perl-Locale-Maketext-Simple-0.21-415.fc28.noarch.rpm ( * Up to
(excluding)
5.26.3-415.fc28
运行在以下环境
系统 fedora_28_Modular perl * Up to
(excluding)
5.26-20181205105946.0dec8aa7
运行在以下环境
系统 fedora_29 perl-Attribute-Handlers-1.01-425.fc29.noarch.rpm ( * Up to
(excluding)
5.28.1-425.fc29
运行在以下环境
系统 fedora_29_Modular perl * Up to
(excluding)
5.26-20181205105946.b88aa309
运行在以下环境
系统 opensuse_Leap_15.0 perl-32bit * Up to
(excluding)
5.26.1-lp150.6.6.1
运行在以下环境
系统 ubuntu_14.04.6_lts perl * Up to
(excluding)
5.18.2-2ubuntu1.6
运行在以下环境
系统 ubuntu_16.04 perl * Up to
(excluding)
5.22.1-9ubuntu0.6
运行在以下环境
系统 ubuntu_16.04.7_lts perl * Up to
(excluding)
5.22.1-9ubuntu0.6
运行在以下环境
系统 ubuntu_18.04 perl * Up to
(excluding)
5.26.1-6ubuntu0.3
运行在以下环境
系统 ubuntu_18.04.5_lts perl * Up to
(excluding)
5.26.1-6ubuntu0.3
运行在以下环境
系统 ubuntu_18.10 perl * Up to
(excluding)
5.26.2-7ubuntu0.1
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-119 内存缓冲区边界内操作的限制不恰当
阿里云安全产品覆盖情况