低危 GNU libiberty拒绝服务漏洞

CVE编号

CVE-2018-18483

利用情况

暂无

补丁情况

官方补丁

披露时间

2018-10-19 10:29:00
漏洞描述
GNU Binutils(又名GNU Binary Utilities或binutils)是GNU计划开发的一组编程语言工具程序,它主要用于处理多种格式的目标文件,并提供有连接器、汇编器和其他用于目标文件和档案的工具。libiberty是其中的一个包含了多个GNU程序软件库。
GNU Binutils 2.31版本中的libiberty的cplus-dem.c文件的‘get_count’函数存在整数溢出漏洞。远程攻击者可借助特制的字符串利用该漏洞造成拒绝服务。
解决建议
厂商尚未提供漏洞修复方案,请关注厂商主页更新:
https://gcc.gnu.org/onlinedocs/libiberty/
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 gnu binutils 2.31 -
2
运行在以下环境
系统 suse_12_SP4 binutils * Up to
(excluding)
2.32-9.33.1
3
运行在以下环境
系统 suse_12_SP5 binutils * Up to
(excluding)
2.32-9.33.1
4
运行在以下环境
系统 debian_11 binutils * Up to
(excluding)
2.35.1-2
5
运行在以下环境
系统 debian_sid binutils * Up to
(excluding)
2.35.1-2
6
运行在以下环境
系统 debian_9 binutils * Up to
(excluding)
2.28-5
7
运行在以下环境
系统 debian_10 binutils * Up to
(excluding)
2.31.1-16
8
运行在以下环境
系统 opensuse_Leap_15.0 binutils * Up to
(excluding)
2.32-lp150.10.1
9
运行在以下环境
系统 opensuse_Leap_15.1 binutils * Up to
(excluding)
2.32-lp151.3.3.1
阿里云评分
2.9
  • 攻击路径
    本地
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-190 整数溢出或超界折返
阿里云安全产品覆盖情况