低危 由于AF_PACKET实施中的竞争条件导致UAF漏洞

CVE编号

CVE-2018-18559

利用情况

暂无

补丁情况

官方补丁

披露时间

2018-10-23
漏洞描述
在Linux内核到4.19中,由于来自setsockopt的fanout_add和AF_PACKET套接字上的绑定之间的竞争条件,可能会发生释放后使用。此问题的存在是因为竞争条件的15fe076edea787807a7cdc168df832544b58eba6不完整。代码错误处理某个涉及packet_do_bind取消注册操作,然后是packet_notifier注册操作的多线程情况。稍后,packet_release仅对两个适用的链接列表中的一个进行操作。攻击者可以实现Program Counter control。

解决建议
厂商已发布漏洞修复程序,请及时关注更新:
https://www.kernel.org/
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 redhat openshift_container_platform 3.11 -
运行在以下环境
应用 redhat virtualization_host 4.0 -
运行在以下环境
系统 linux linux_kernel * Up to
(including)
4.19
运行在以下环境
系统 redhat enterprise_linux_desktop 7.0 -
运行在以下环境
系统 redhat enterprise_linux_server 7.0 -
运行在以下环境
系统 redhat enterprise_linux_server_aus 7.6 -
运行在以下环境
系统 redhat enterprise_linux_server_eus 7.6 -
运行在以下环境
系统 redhat enterprise_linux_server_tus 7.6 -
运行在以下环境
系统 redhat enterprise_linux_workstation 7.0 -
运行在以下环境
系统 redhat_7 bpftool * Up to
(excluding)
0:3.10.0-957.5.1.el7
运行在以下环境
系统 redhat_7 kernel-rt * Up to
(excluding)
0:3.10.0-957.5.1.rt56.916.el7
运行在以下环境
系统 ubuntu_14.04_lts linux-aws * Up to
(excluding)
4.4.0-1016.16
运行在以下环境
系统 ubuntu_16.04_lts linux * Up to
(excluding)
4.4.0-119.143
运行在以下环境
系统 ubuntu_18.04_lts linux * Up to
(excluding)
4.15.0-10.11
运行在以下环境
系统 ubuntu_18.10 linux * Up to
(excluding)
4.15.0-20.21
阿里云评分
2.7
  • 攻击路径
    远程
  • 攻击复杂度
    困难
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-362 使用共享资源的并发执行不恰当同步问题(竞争条件)
CWE-416 释放后使用
阿里云安全产品覆盖情况