grafana grafana 在web页面生成时对输入的转义处理不恰当(跨站脚本)

CVE编号

CVE-2018-18623

利用情况

暂无

补丁情况

N/A

披露时间

2020-06-03
漏洞描述
Grafana是Grafana实验室的一套提供可视化监控界面的开源监控工具。该工具主要用于监控和分析Graphite、InfluxDB和Prometheus等。

Grafana 5.3.1版本中存在跨站脚本漏洞。该漏洞源于WEB应用缺少对客户端数据的正确验证。攻击者可利用该漏洞执行客户端代码。
解决建议
目前厂商已发布升级补丁以修复漏洞,补丁获取链接:
https://github.com/grafana/grafana/pull/11813
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 grafana grafana 5.3.1 -
CVSS3评分
6.1
  • 攻击路径
    网络
  • 攻击复杂度
  • 权限要求
  • 影响范围
    已更改
  • 用户交互
    需要
  • 可用性
  • 保密性
  • 完整性
CWE-ID 漏洞类型
CWE-79 在Web页面生成时对输入的转义处理不恰当(跨站脚本)
阿里云安全产品覆盖情况