中危 Digium Asterisk 缓冲区错误漏洞

CVE编号

CVE-2018-19278

利用情况

暂无

补丁情况

官方补丁

披露时间

2018-11-15
漏洞描述
Digium Asterisk是美国Digium公司的一套开源电话交换机(PBX)系统软件。该软件支持语音信箱、多方语音会议、交互式语音应答(IVR)等。
Digium Asterisk 15.6.2之前的15.x版本和16.0.1之前的16.x版本中的DNS SRV和NAPTR查询存在缓冲区溢出漏洞,该漏洞源于程序使用压缩之后的长度而不是扩展之后的长度来匹配缓冲区的大小。远程攻击者可借助特制的DNS SRV或NAPTR响应利用该漏洞造成Asterisk崩溃。

解决建议
建议您更新当前系统或软件至最新版,完成漏洞的修复。
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 digium asterisk 15.0.0 -
运行在以下环境
应用 digium asterisk 15.1.0 -
运行在以下环境
应用 digium asterisk 15.1.2 -
运行在以下环境
应用 digium asterisk 15.1.3 -
运行在以下环境
应用 digium asterisk 15.1.4 -
运行在以下环境
应用 digium asterisk 15.1.5 -
运行在以下环境
应用 digium asterisk 15.2.0 -
运行在以下环境
应用 digium asterisk 15.2.1 -
运行在以下环境
应用 digium asterisk 15.2.2 -
运行在以下环境
应用 digium asterisk 15.3.0 -
运行在以下环境
应用 digium asterisk 15.4.0 -
运行在以下环境
应用 digium asterisk 15.4.1 -
运行在以下环境
应用 digium asterisk 15.5.0 -
运行在以下环境
应用 digium asterisk 15.6.0 -
运行在以下环境
应用 digium asterisk 15.6.1 -
运行在以下环境
应用 digium asterisk 16.0.0 -
运行在以下环境
应用 digium asterisk 16.0.1 -
运行在以下环境
系统 alpine_3.10 asterisk * Up to
(excluding)
15.7.1-r0
运行在以下环境
系统 alpine_3.11 asterisk * Up to
(excluding)
15.7.1-r0
运行在以下环境
系统 alpine_3.12 asterisk * Up to
(excluding)
15.7.1-r0
运行在以下环境
系统 alpine_3.13 asterisk * Up to
(excluding)
15.7.1-r0
运行在以下环境
系统 alpine_3.14 asterisk * Up to
(excluding)
15.7.1-r0
运行在以下环境
系统 alpine_3.15 asterisk * Up to
(excluding)
15.7.1-r0
运行在以下环境
系统 alpine_3.16 asterisk * Up to
(excluding)
15.7.1-r0
运行在以下环境
系统 alpine_3.7 asterisk * Up to
(excluding)
15.6.2-r0
运行在以下环境
系统 alpine_3.8 asterisk * Up to
(excluding)
15.6.2-r0
运行在以下环境
系统 alpine_3.9 asterisk * Up to
(excluding)
15.7.1-r0
运行在以下环境
系统 alpine_edge asterisk * Up to
(excluding)
15.7.1-r0
阿里云评分
6.5
  • 攻击路径
    远程
  • 攻击复杂度
    容易
  • 权限要求
    无需权限
  • 影响范围
    全局影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    DoS
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-119 内存缓冲区边界内操作的限制不恰当
阿里云安全产品覆盖情况