中危 Jupyter Notebook 跨站脚本漏洞

CVE编号

CVE-2018-19351

利用情况

暂无

补丁情况

官方补丁

披露时间

2018-11-19
漏洞描述
Jupyter Notebook是一套用于创建、共享代码和说明性文本文档的开源Web应用程序。
Jupyter Notebook 5.7.1之前版本中存在跨站脚本漏洞,该漏洞源于在notebook/nbconvert/handlers.py文件中,NbconvertFileHandler和NbconvertPostHandler没有设置内容安全策略。远程攻击者可利用该漏洞注入任意的Web脚本或HTML。

解决建议
厂商已发布了漏洞修复程序,请及时关注更新:
https://pypi.org/project/notebook/#history
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 jupyter notebook * Up to
(excluding)
5.7.1
运行在以下环境
系统 debian_9 jupyter-notebook * Up to
(excluding)
4.2.3-4+deb9u1
运行在以下环境
系统 fedora_28 jupyter-notebook * Up to
(excluding)
5.5.0-6.fc28
运行在以下环境
系统 fedora_29 jupyter-notebook * Up to
(excluding)
5.7.2-1.fc29
阿里云评分
4.9
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    越权影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-79 在Web页面生成时对输入的转义处理不恰当(跨站脚本)
阿里云安全产品覆盖情况