低危 使用uid> INT_MAX对用户进行不正确的处理会导致身份验证绕过

CVE编号

CVE-2018-19788

利用情况

暂无

补丁情况

官方补丁

披露时间

2018-12-03
漏洞描述
在PolicyKit(aka polkit)0.115中发现了一个缺陷,它允许uid大于INT_MAX的用户成功执行任何systemctl命令。

解决建议
厂商已发布了漏洞修复程序,请及时关注更新:
https://gitlab.freedesktop.org/zbyszek/polkit/commit/fbaab32cb4ed9ed5f1e3eea6cd317d443aa427dc
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 polkit_project polkit 0.115 -
运行在以下环境
系统 alpine_3.6 polkit * Up to
(excluding)
0.105-r8
运行在以下环境
系统 alpine_3.7 polkit * Up to
(excluding)
0.105-r8
运行在以下环境
系统 alpine_3.8 polkit * Up to
(excluding)
0.105-r9
运行在以下环境
系统 alpine_3.9 polkit * Up to
(excluding)
0.105-r9
运行在以下环境
系统 amazon_2 polkit * Up to
(excluding)
0.112-22.amzn2.1
运行在以下环境
系统 debian_8 polkit * Up to
(excluding)
0.105-15~deb8u4
运行在以下环境
系统 debian_9 polkit * Up to
(excluding)
0.105-18+deb9u1
运行在以下环境
系统 fedora_28 polkit * Up to
(excluding)
0.115-2.fc28
运行在以下环境
系统 fedora_29 polkit * Up to
(excluding)
0.115-4.1.fc29
运行在以下环境
系统 opensuse_Leap_15.0 polkit * Up to
(excluding)
0.114-lp150.2.6.1
运行在以下环境
系统 opensuse_Leap_42.3 polkit * Up to
(excluding)
0.113-14.6.1
运行在以下环境
系统 oracle_7 polkit * Up to
(excluding)
0.112-22.0.1.el7
运行在以下环境
系统 redhat_7 polkit * Up to
(excluding)
0:0.112-22.el7
运行在以下环境
系统 suse_12 libpolkit0-32bit * Up to
(excluding)
0.113-5.18
运行在以下环境
系统 suse_12_SP3 polkit * Up to
(excluding)
0.113-5.15.1
运行在以下环境
系统 suse_12_SP4 polkit * Up to
(excluding)
0.113-5.15.1
运行在以下环境
系统 ubuntu_14.04 polkit * Up to
(excluding)
0.105-4ubuntu3.14.04.5
运行在以下环境
系统 ubuntu_14.04.6_lts policykit-1 * Up to
(excluding)
0.105-4ubuntu3.14.04.5
运行在以下环境
系统 ubuntu_16.04 polkit * Up to
(excluding)
0.105-14.1ubuntu0.4
运行在以下环境
系统 ubuntu_16.04.7_lts policykit-1 * Up to
(excluding)
0.105-14.1ubuntu0.4
运行在以下环境
系统 ubuntu_18.04 polkit * Up to
(excluding)
0.105-20ubuntu0.18.04.4
运行在以下环境
系统 ubuntu_18.04.5_lts policykit-1 * Up to
(excluding)
0.105-20ubuntu0.18.04.4
运行在以下环境
系统 ubuntu_18.10 policykit-1 * Up to
(excluding)
0.105-21ubuntu0.3
阿里云评分
2.7
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    普通权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-20 输入验证不恰当
阿里云安全产品覆盖情况