低危 由于IS_CONTAINED_BY_LMA宏导致拒绝服务导致整数溢出

CVE编号

CVE-2018-19932

利用情况

暂无

补丁情况

官方补丁

披露时间

2018-12-07
漏洞描述
在二进制文件描述符(BFD)库(又名libbfd)中发现了一个问题,该库在GNU Binutils到2.31发行。elf.c中的IS_CONTAINED_BY_LMA宏会导致整数溢出和无限循环。
解决建议
厂商已发布漏洞修复程序,请及时关注更新:
https://sourceware.org/git/gitweb.cgi?p=binutils-gdb.git;h=beab453223769279cc1cef68a1622ab8978641f7
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 gnu binutils * Up to
(including)
2.31
运行在以下环境
应用 netapp vasa_provider * From
(including)
7.2
运行在以下环境
系统 alpine_3.10 binutils * Up to
(excluding)
2.32-r0
运行在以下环境
系统 alpine_3.11 binutils * Up to
(excluding)
2.32-r0
运行在以下环境
系统 alpine_3.12 binutils * Up to
(excluding)
2.32-r0
运行在以下环境
系统 alpine_3.13 binutils * Up to
(excluding)
2.32-r0
运行在以下环境
系统 alpine_3.14 binutils * Up to
(excluding)
2.32-r0
运行在以下环境
系统 alpine_3.15 binutils * Up to
(excluding)
2.32-r0
运行在以下环境
系统 alpine_edge binutils * Up to
(excluding)
2.32-r0
运行在以下环境
系统 debian_10 binutils * Up to
(excluding)
2.31.1-16
运行在以下环境
系统 debian_9 binutils * Up to
(excluding)
2.28-5
运行在以下环境
系统 opensuse_Leap_15.0 binutils * Up to
(excluding)
2.32-lp150.10.1
运行在以下环境
系统 opensuse_Leap_15.1 binutils * Up to
(excluding)
2.32-lp151.3.3.1
运行在以下环境
系统 suse_12_SP4 binutils * Up to
(excluding)
2.32-9.33.1
运行在以下环境
系统 suse_12_SP5 binutils * Up to
(excluding)
2.32-9.33.1
运行在以下环境
系统 ubuntu_16.04 binutils * Up to
(excluding)
2.26.1-1ubuntu1~16.04.8+esm1
运行在以下环境
系统 ubuntu_18.04 binutils * Up to
(excluding)
2.30-21ubuntu1~18.04.3
阿里云评分
2.9
  • 攻击路径
    本地
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-190 整数溢出或超界折返
阿里云安全产品覆盖情况