低危 ImageMagick 'ReadBMPImage ()' 函数拒绝服务漏洞

CVE编号

CVE-2018-20185

利用情况

暂无

补丁情况

官方补丁

披露时间

2018-12-18
漏洞描述
在32位平台上的GraphicsMagick 1.4 snapshot-20181209 Q8中,bmp.c的ReadBMPImage函数中存在基于堆的缓冲区过度读取,允许攻击者通过精心设计的bmp映像文件导致拒绝服务。这仅影响具有自定义BMP限制的GraphicsMagick安装。<br>
解决建议
建议您更新当前系统或软件至最新版,完成漏洞的修复。
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 graphicsmagick graphicsmagick 1.4 -
运行在以下环境
系统 debian_8 graphicsmagick * Up to
(excluding)
1.3.20-3+deb8u2
运行在以下环境
系统 debian_9 graphicsmagick * Up to
(excluding)
1.3.30+hg15796-1~deb9u3
运行在以下环境
系统 fedora_EPEL_7 graphicsmagick * Up to
(excluding)
1.3.34-1.el7
运行在以下环境
系统 fedora_EPEL_8 graphicsmagick * Up to
(excluding)
1.3.34-1.el8
运行在以下环境
系统 ubuntu_18.04 graphicsmagick * Up to
(excluding)
1.3.28-2ubuntu0.1
运行在以下环境
系统 ubuntu_18.04.5_lts graphicsmagick * Up to
(excluding)
1.3.28-2ubuntu0.1
阿里云评分
2.7
  • 攻击路径
    远程
  • 攻击复杂度
    困难
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-125 跨界内存读
阿里云安全产品覆盖情况